ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Antworten
Benutzeravatar
Jens
User
Beiträge: 1127
Registriert: 23.08.2005, 13:31
Wohnort: D-31582 Nienburg/Weser

ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Beitrag von Jens » 13.10.2006, 22:14

Hallo!

Ich habe mir aus dem Netz ein .o-file (ZX80-Format) heruntergeladen und möchte es so kurz wie nur möglich auf meinem Windowsrechner behalten (Imageschaden...).

Meine ZX81-files (.p-file) bekomme ich mit ZXTape v3.0 problemlos in den ZX81. Allerdings funzt das nicht mit dem ZX80...tja...

Wer hat eine Idee/Lösung/Vorschlag/möchte reden/sonstiges ?

Für Hilfe dankbar
Jens
Der ZX81 rechnet mit allem, nur nicht mit seinem Besitzer...
Neues aus der KI-Welt... Die Automate kann sich selbst essen.

Benutzeravatar
nils.eilers
User
Beiträge: 111
Registriert: 31.01.2005, 14:07
Wohnort: Leverkusen
Kontaktdaten:

Beitrag von nils.eilers » 17.10.2006, 15:56

Hallo Jens!

Load & Save von Bodo Wenzel kann Programme von und zum ZX80 übertragen: http://bodo4all.cwsurf.de/zx/loadsave.html


Anders als ZX-TAPE macht Load & Save das Timing nicht mit Verzögerungsschleifen, die stark von der Rechnergeschwindigkeit und einer entsprechenden Kalibration abhängig sind, sondern überlässt diese Arbeit dem UART, also dem Controller der seriellen Schnittstelle - und sorgt damit recht clever dafür, dass das Timing stimmt. 4800 Baud z.B. sind eben 4800 Baud, egal wie schnell der Rechner ist. Hat sich Bodo wirklich fein ausgedacht!

Die schlechte Nachricht lautet: Du musst Dir ein neues Kabel löten!

Viel Erfolg!

Ich hab' selbst mit Load & Save noch nicht gearbeitet, lass mal lesen, wie's geklappt hat!

Viele Grüsse,
Nils


edit 2008-11-12: Internetadresse aktualisiert
Zuletzt geändert von nils.eilers am 12.11.2008, 07:04, insgesamt 1-mal geändert.

Benutzeravatar
Jens
User
Beiträge: 1127
Registriert: 23.08.2005, 13:31
Wohnort: D-31582 Nienburg/Weser

Beitrag von Jens » 17.10.2006, 18:33

Hallo Nils!

Danke für Deine (schnelle) Antwort...

Klaus Jahnke arbeitet mit Load&Save von Bodo. Somit habe ich einen Grund, Klaus demnächst mal zu besuchen. Aber ich werde auch an selbst Hand anlegen (der Lötkolben ist schon fast eingefroren).

Ich berichte dann!

Gruss
Jens
Der ZX81 rechnet mit allem, nur nicht mit seinem Besitzer...
Neues aus der KI-Welt... Die Automate kann sich selbst essen.

Werner
User
Beiträge: 22
Registriert: 14.09.2014, 21:29

Re: ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Beitrag von Werner » 01.01.2018, 23:35

Hallo,
kann mir jemand zu dieser alten Anfrage von Jens eine aktuelle Antwort geben?
Grüße
Werner

Benutzeravatar
Paul
User
Beiträge: 2725
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Beitrag von Paul » 02.01.2018, 06:35

Das Programm p2wav kann, trotz seines Namens, .O Dateien in .wav verwandeln.
Aber Achtung! Der ZX80 ist im original Zustand fast taub.
Ich aber verwende dafür einen alten ZXPand den Sirmorris mir auf ZX80 umgebaut hat. Der neue ist ZXPand+ ist dafür nicht mehr ausgelegt.
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Benutzeravatar
msch
User
Beiträge: 3747
Registriert: 05.02.2013, 15:42
Wohnort: Hessen, Rhein-Main-Gebiet

Re: ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Beitrag von msch » 02.01.2018, 07:29

Bodo‘s website ist inzw. umgezogen. Das Prgramm ist nun hier zu finden:
http://bodo4all.fortunecity.ws/zx/loadsave.html
manche meinen lechts und rinks kann man nicht velwechsern.
werch ein illtum! (lichtung, Ernst Jandl)

Benutzeravatar
PokeMon
User
Beiträge: 4706
Registriert: 31.08.2011, 23:41

Re: ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Beitrag von PokeMon » 02.01.2018, 11:17

Die ZX-IDE kann auch .o Programme in WAV wandeln.
Dazu muss man sie einmal übertragen und wenn "Auto Create WAV" aktiviert ist, wird das WAV parallel erstellt.
Man wählt dazu F10 (transfer other file).
Oder man nutzt direkt die Funktion "Create WAV from file". Habe gerade gesehen, dass ich das auch programmiert habe. :lol:

Und Paul hat Recht, man braucht einen hohen Ausgangspegel, den nicht jede onboard Soundkarte schafft. Eventuell braucht es noch einen kleinen Verstärker.

Allgemeine Hinweise zum WAV Transfer gibt es auch hier:
(die IDE ist im ersten Beitrag des Threads als Download zu finden, läuft aber nur unter WIN).
viewtopic.php?f=2&t=802#p6982

Bildschirmfoto 2018-01-02 um 11.14.44.png
Bildschirmfoto 2018-01-02 um 11.14.44.png (20.81 KiB) 1052 mal betrachtet
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
Jens
User
Beiträge: 1127
Registriert: 23.08.2005, 13:31
Wohnort: D-31582 Nienburg/Weser

Re: ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Beitrag von Jens » 02.01.2018, 18:54

Olli (holmatic) hat mal dieses kleine feine Programm geschrieben (für WinDoof/DOS), welches das gut wandelt...
zxp2wav.zip
(27.47 KiB) 29-mal heruntergeladen
Aber Paul hat recht. Der ZX80 ist schwerhörig. Aber Paul ist dem ZX80 auch schwer hörig (Achtung, Flachwitz)...

Gruß
Jens

P.S.: Ich benutze einen einfachen Kopfhörerverstärker - das klappt ganz gut...
Der ZX81 rechnet mit allem, nur nicht mit seinem Besitzer...
Neues aus der KI-Welt... Die Automate kann sich selbst essen.

Werner
User
Beiträge: 22
Registriert: 14.09.2014, 21:29

Re: ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Beitrag von Werner » 02.01.2018, 22:05

Danke euch allen.
zxp2wav.exe kommt scheinbar mit meinem 64er Win10 nicht zurecht. Macht aber nix, da die ZX-IDE einwandfrei arbeitet. Leider ist aber tatsächlich der Ausgangspegel auch meiner Soundkarte nicht hoch genug und ich muss wir wohl doch noch einen kleinen Audioverstärker dazwischensetzen.
Gruß
Werner

Benutzeravatar
PokeMon
User
Beiträge: 4706
Registriert: 31.08.2011, 23:41

Re: ZX80: Wie bekomme ich ein *.o-file in den Originalrechner???

Beitrag von PokeMon » 02.01.2018, 23:12

Du solltest die FAST Loader Option auf jeden Fall abschalten (wenn das die IDE nicht automatisch macht bei ZX80 *.o).
Manchmal hauen diverse Audioplayer noch dazwischen, die oft die Daten (Audio) nicht ganz ungefiltert rausgeben.
Das sind Nuancen, die man oft akustisch nicht wahrnimmt.
WIN Mediaplayer funktioniert ganz gut, mit VLC Player hatte ich nie Erfolg.

Dieses ZX80DEMO.WAV (als ZIP) sollte eigentlich funktionieren, stammt aus einer früheren Testphase in den ersten Versionen der IDE.
Dateianhänge
ZX80DEMO.wav.zip
(3.5 KiB) 28-mal heruntergeladen
Wer seinen Computer ehrt, lebt nicht verkehrt.

Antworten