Blauer Engel Diskussionen

ZX-Team Forum
Benutzeravatar
PokeMon
User
Beiträge: 4032
Registriert: 31.08.2011, 23:41

Re: Blauer Engel Diskussionen

Beitrag von PokeMon » 23.08.2015, 21:44

So - mein blauer Engel läuft. 8)
Nachdem der Engel endlich eingetroffen ist am Freitag, habe ich am WE das Ding mal zusammengebaut.
Die Stiftleisten sitzen etwas eng, ist aber vermutlich systemimmanent beim blauen Engel.
Hat Paul ja auch geschrieben.

Als Power Buchse habe ich standesgemäß die ZX81 CLIFF Klinkenbuchse und das Original Netzteil vom Zeddy verwendet.
Läuft prima. 8)
IMG_8726k.JPG
IMG_8726k.JPG (213.54 KiB) 5734 mal betrachtet
IMG_8728k.JPG
IMG_8728k.JPG (156.55 KiB) 5734 mal betrachtet
IMG_8731k.JPG
IMG_8731k.JPG (184.05 KiB) 5734 mal betrachtet
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
PokeMon
User
Beiträge: 4032
Registriert: 31.08.2011, 23:41

Re: Blauer Engel Diskussionen

Beitrag von PokeMon » 23.08.2015, 21:52

Nach dem Einschalten blinkt der blaue Engel wie ein Christbaum mit dem offensichtlichen Startprogramm, verschwindet aber nach der Programmierung. :mrgreen:

Die Programmierung hat soweit auch funktioniert, nachdem ich den ASP (Active Serial Port) verwendet habe. Mit JTAG funktioniert es offenbar nicht resp. gibt das Board einen anderen Typ von Altera wieder, der mit dem Programmfile nicht verwendbar ist. Bei Gelegenheit muss ich mir mal die Unterschiede zwischen JTAG und ASP ansehen, bislang habe ich immer JTAG verwendet bei meinen CPLD's.

Das Startbild kam sofort - allerdings weiße Schrift auf schwarzem Grund. Das ändert sich auch nicht, wenn dann der ZXNU geladen wird.
Gibt es da einen Trick um schwarze Schrift auf weißem Hintergrund zu bekommen, oder ist das einfach nicht vorgesehen ?
IMG_8733k.JPG
IMG_8733k.JPG (124.61 KiB) 5734 mal betrachtet
Die Tastatur über den 8-poligen und 5-poligen Steckverbinder funktioniert auch ohne Probleme - einzig hätte man die Steckverbinder etwa 3mm weiter auseinander positionieren können, dann hätte meine Tastatur wie beim NU auch ohne Flachkabel funktioniert. So waren die Pins einfach zu eng.
IMG_8734k.JPG
IMG_8734k.JPG (193.13 KiB) 5734 mal betrachtet
Ich kann wie Torsten auch nachvollziehen, dass beim Druck auf 1,2,3 usw. die Meldung mehrfach kommt (Datei nicht gefunden) was aber offenbar nicht stört wenn die richtige Datei aufgerufen und auf dem Stick gefunden und offenbar sofort verarbeitet wird.

Wofür ist SV3 gedacht und kann man den Serial Port verwenden ?

Ansonsten sehr schöne Arbeit und lief auf Anhieb problemlos. 8)
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
PokeMon
User
Beiträge: 4032
Registriert: 31.08.2011, 23:41

Re: Blauer Engel Diskussionen

Beitrag von PokeMon » 23.08.2015, 21:56

tokabln hat geschrieben:trotzdem würde ich gerne Wissen warum die Tasten 0, 1 und 3 scheinbar prellen und was Load <Tastennummer> und BF bedeutet und warum das bei mir nicht auch für die Tasten 4 + 5 erscheint
LOAD ... BF = Load ... binary failed ? :mrgreen:
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
Joachim
User
Beiträge: 721
Registriert: 06.11.2004, 20:21

Re: Blauer Engel Diskussionen

Beitrag von Joachim » 23.08.2015, 23:03

Hallo Paul,
habe heute den blauen Engel mit Erfolg zusammengebaut. ZX81NU läuft tadellos. Hatte ursprünglich Probleme beim Start des VDRIVE. Die LED machte keinen Mucks. Nachdem ich die Muttern abmontierte, um das VDRIVE näher zu untersuchen, lief es tadellos. Evtl. eine Spannung auf der Platine. Tolles Projekt. Jetzt bin ich gespannt auf die nächste Systemdatei.

Wäre super, wenn ein 8 Bit-GPIO dabei wäre.

Noch ein Hinweis zum Aufbau:
Ich habe zuerst die gewinkelte Buchsenleiste für den Anschluß des VDRIVE eingelötet und dann das VDRIVE eingesteckt. Dabei mußte ich feststellen, dass die Buchsenleiste nicht hoch genug ist. Es hängt davon ab, wie tief die Stiftleiste auf dem VDRIVE eingelötet ist. Das kann unterschiedlich sein. Ich mußte deshalb die Buchsenleiste rausflexen, damit ich sie entlöten konnte. Am besten geht man so vor:
Am VDRIVE die dicken Pins für die USB-Buchsenbefestigung soweit als möglich abknipsen. Die M1,6-Schrauben durch die BAMM-Platine stecken und mit einer Mutter anziehen. Die Buchsenleiste an das VDRIVE anstecken und dann das Ganze auf die Schrauben aufsetzen und die Pins der Buchsenleiste in die Platine stecken. Ist fummelig, geht aber. Dann die zweite Mutter befestigen und dann die Pins anlöten. Damit steht die Buchsenleiste evtl. etwas über der Platine, es gibt aber keine Spannungen auf der VDRIVE-Platine.
Vorsicht beim Befestigen der kleinen Muttern auf dem VDRIVE mit einer Flachzange: An einer Seite ist ein SMD-Kondensator so nahe an der Mutter, dass man beim Drehen mit der Flachzange den Kondensator abreissen kann!

Viele Grüße!
Joachim
Viele Grüße!
Joachim


ZX80, ZX81, ZX-Spectrum, ZX96, ZX2000, ZXmore, ZX81NU, Blauer Engel, AX81

Benutzeravatar
PokeMon
User
Beiträge: 4032
Registriert: 31.08.2011, 23:41

Re: Blauer Engel Diskussionen

Beitrag von PokeMon » 24.08.2015, 15:04

Gibt es für Dummies wie mich irgendwo eine Kurzanleitung, wie man mit dem LOAD Kommando vom VDRIVE laden und speichern kann ?
Ist ja mein erstes VDRIVE. :D
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
msch
User
Beiträge: 3036
Registriert: 05.02.2013, 15:42
Wohnort: Hessen, Rhein-Main-Gebiet

Re: Blauer Engel Diskussionen

Beitrag von msch » 24.08.2015, 15:17

manche meinen lechts und rinks kann man nicht velwechsern.
werch ein illtum! (Lichtung, Ernst Jandl)

Benutzeravatar
tokabln
User
Beiträge: 792
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: Blauer Engel Diskussionen

Beitrag von tokabln » 24.08.2015, 21:23

... oder Du lädst die Befehle gleich als PDF Datei herunter.

download/file.php?id=3431
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
tokabln
User
Beiträge: 792
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: Blauer Engel Diskussionen

Beitrag von tokabln » 24.08.2015, 21:28

@Karl: direkt an einem VGA Monitor betrieben habe ich schwarze Schrift auf weissem Grund :?:
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
PokeMon
User
Beiträge: 4032
Registriert: 31.08.2011, 23:41

Re: Blauer Engel Diskussionen

Beitrag von PokeMon » 24.08.2015, 21:45

Ja - habe ich auch.
Parallel am Videoausgang ist es genau invertiert. :wink:
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
tokabln
User
Beiträge: 792
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: Blauer Engel Diskussionen

Beitrag von tokabln » 24.08.2015, 21:47

Ah... okay, den habe ich noch nicht getestet. :mrgreen:
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
msch
User
Beiträge: 3036
Registriert: 05.02.2013, 15:42
Wohnort: Hessen, Rhein-Main-Gebiet

Re: Blauer Engel Diskussionen

Beitrag von msch » 24.08.2015, 21:59

PokeMon hat geschrieben:Ja - habe ich auch.
Parallel am Videoausgang ist es genau invertiert. :wink:
Ist das ein feature oder ein bug?
manche meinen lechts und rinks kann man nicht velwechsern.
werch ein illtum! (Lichtung, Ernst Jandl)

Benutzeravatar
Paul
User
Beiträge: 2189
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: Blauer Engel Diskussionen

Beitrag von Paul » 24.08.2015, 22:09

Ein Feature. Ich benutze beide Eingänge am gleichen Monitor und sehe so ob ich via Video oder VGA reingehe So muss ich nicht immer hin und her schalten um zu wissen welches Signal ich gerade beobachte.
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Benutzeravatar
Paul
User
Beiträge: 2189
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: Blauer Engel Diskussionen

Beitrag von Paul » 26.08.2015, 13:03

PokeMon hat geschrieben:Die Programmierung hat soweit auch funktioniert, nachdem ich den ASP (Active Serial Port) verwendet habe. Mit JTAG funktioniert es offenbar nicht resp. gibt das Board einen anderen Typ von Altera wieder, der mit dem Programmfile nicht verwendbar ist. Bei Gelegenheit muss ich mir mal die Unterschiede zwischen JTAG und ASP ansehen, bislang habe ich immer JTAG verwendet bei meinen CPLD's.
Das JTAG programmiert den FPGA Baustein, der auf RAM basiert. So kann mann sehr schön testen, beim nächsten Einschalten ist wieder alles wie vorher.
Bei AS wird "nur" das EEPROM programmiert (separater Baustein). Aus diesem wird beim Einschalten der Inhalt in das RAM des FPGA geladen. Das ist also dauerhafter.
PokeMon hat geschrieben:Die Tastatur über den 8-poligen und 5-poligen Steckverbinder funktioniert auch ohne Probleme - einzig hätte man die Steckverbinder etwa 3mm weiter auseinander positionieren können, dann hätte meine Tastatur wie beim NU auch ohne Flachkabel funktioniert. So waren die Pins einfach zu eng.
Ja, das hatte ich mal kurz irgendwo beschrieben, ich glaube in der Aufbauanleitung.
Bei der nächsten Platinenversion ist dieser Fehler behoben. Darum kümmere ich mich aber erst nach Wittenberg.
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Benutzeravatar
schombi
User
Beiträge: 1862
Registriert: 05.09.2012, 09:45
Wohnort: Kreis KA

Re: Blauer Engel Diskussionen

Beitrag von schombi » 30.10.2015, 19:41

Ich habe den idealen Monitor für den blauen Engel gefunden. Einen Viewsonic MD-935A. Der ist S/W, ist winzige 9" klein, hat ein super sauberes Bild und schreit geradezu danach 2016 nach Mahlerts mitgenommen zu werden. Der Monitor ist in einem absoluten Topzustand und stammt ebenfalls aus dem Sinclair-Nachlass. Laut seiner Frau wurde der Monitor eigens für Treffen angeschafft.
moni.jpg
moni.jpg (29.19 KiB) 5493 mal betrachtet
http://www.cnet.com/products/viewmagic- ... r-9/specs/

Benutzeravatar
msch
User
Beiträge: 3036
Registriert: 05.02.2013, 15:42
Wohnort: Hessen, Rhein-Main-Gebiet

Re: Blauer Engel Diskussionen

Beitrag von msch » 30.10.2015, 21:35

Kein Viewsonic, sondern Viewmagic. Ein VGA-Monochrom-Monito, vermutlich für POS, in 9 Zoll - nettes Teil, habe ich auch ;-)
manche meinen lechts und rinks kann man nicht velwechsern.
werch ein illtum! (Lichtung, Ernst Jandl)

Benutzeravatar
schombi
User
Beiträge: 1862
Registriert: 05.09.2012, 09:45
Wohnort: Kreis KA

Re: Blauer Engel Diskussionen

Beitrag von schombi » 31.10.2015, 07:28

Du hast natürlich Recht Mathias, habe wohl geistig neben mir gestanden. Selbst auf der von mir verlinkten Seite steht Viewmagic... :oops:

Benutzeravatar
siggi
User
Beiträge: 1719
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, Ranstadt-Dauernheim
Kontaktdaten:

Re: Blauer Engel Diskussionen

Beitrag von siggi » 31.10.2015, 13:20

Achtung: Mein Virenscanner springt an, wenn man diesen Link anklickt :evil:

Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Benutzeravatar
schombi
User
Beiträge: 1862
Registriert: 05.09.2012, 09:45
Wohnort: Kreis KA

Re: Blauer Engel Diskussionen

Beitrag von schombi » 31.10.2015, 15:25

?!? Mein NOD32 verhält sich friedlich. Es gibt ja auch nichts runterzuladen oder anzuklicken. Vielleicht missfällt Deinem Scanner das integrierte Popup, welches einen von einer Cnet Mitgliedschaft zu überzeugen versucht.

Benutzeravatar
msch
User
Beiträge: 3036
Registriert: 05.02.2013, 15:42
Wohnort: Hessen, Rhein-Main-Gebiet

Re: Blauer Engel Diskussionen

Beitrag von msch » 31.10.2015, 15:37

Das halte ich für einen false positive. Ein malware scan fördert nichts verdächtiges zutage:
https://sitecheck.sucuri.net/results/ww ... r-9/specs/
manche meinen lechts und rinks kann man nicht velwechsern.
werch ein illtum! (Lichtung, Ernst Jandl)

Benutzeravatar
siggi
User
Beiträge: 1719
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, Ranstadt-Dauernheim
Kontaktdaten:

Re: Blauer Engel Diskussionen

Beitrag von siggi » 31.10.2015, 16:21

Meiner (G Data Internet Security) regt sich nach dem Laden der Seite 4 mal auf: die erste Meldung lautet:
"Virus beim Laden von Web-Inhalten gefunden.

Adresse: http://d.pzkysq.pink/ads.bmp?z=126147714615
Status: Der Zugriff wurde verweigert."

Die anderen so ähnlich.

Gruß
Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Benutzeravatar
PokeMon
User
Beiträge: 4032
Registriert: 31.08.2011, 23:41

Re: Blauer Engel Diskussionen

Beitrag von PokeMon » 31.10.2015, 18:37

Comodo meckert hier nicht. :wink:
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
msch
User
Beiträge: 3036
Registriert: 05.02.2013, 15:42
Wohnort: Hessen, Rhein-Main-Gebiet

Re: Blauer Engel Diskussionen

Beitrag von msch » 31.10.2015, 18:43

Interessant, virustotal meldet hier bei der .pink domain 2 von 65 treffern:
https://www.virustotal.com/de/url/61d71 ... 446313241/
Einer davon ist eine malware domain blacklist und der andere eine firewall block list.

Bei der cnet seite gibt es hingegen keinen Treffer:
https://www.virustotal.com/de/url/da612 ... 446313569/
manche meinen lechts und rinks kann man nicht velwechsern.
werch ein illtum! (Lichtung, Ernst Jandl)

Benutzeravatar
msch
User
Beiträge: 3036
Registriert: 05.02.2013, 15:42
Wohnort: Hessen, Rhein-Main-Gebiet

Re: Blauer Engel Diskussionen

Beitrag von msch » 31.10.2015, 18:53

schombi hat geschrieben:Es gibt ja auch nichts runterzuladen oder anzuklicken.
Das bedeutet leider rein gar nichts. In Zeiten, in denen die Ganoven Inhalte über Werbenetzwerke verteilen (Du bekommst dann eine manipulierte Werbung mit Schadcode ausgeliefert, dagegen können die Websitebetreiber wenig tun), reicht bereits der Besuch der website aus. Deshalb ist der Einsatz von Virenscannern, die sich in den Webbrowser einklinken, auch eine gute Idee, weil zumindest das Risiko vermindert wird. Kostenlos gibt es übrigens für Safari, Chrome und Firefox "Bitdefender Trafficlight", welches vor bekannten Malwaresites warnt.im Falle des Falles wird die Seite mit einem deutlichen Hinweis blockiert. Jetzt sind wir aber off-topic...
manche meinen lechts und rinks kann man nicht velwechsern.
werch ein illtum! (Lichtung, Ernst Jandl)

Benutzeravatar
Paul
User
Beiträge: 2189
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: Blauer Engel Diskussionen

Beitrag von Paul » 08.02.2016, 08:25

schombi hat geschrieben:Ich habe den idealen Monitor für den blauen Engel gefunden. Einen Viewsonic MD-935A. Der ist S/W, ist winzige 9" klein, hat ein super sauberes Bild und schreit geradezu danach 2016 nach Mahlerts mitgenommen zu werden. Der Monitor ist in einem absoluten Topzustand und stammt ebenfalls aus dem Sinclair-Nachlass. Laut seiner Frau wurde der Monitor eigens für Treffen angeschafft.
moni.jpg
http://www.cnet.com/products/viewmagic- ... r-9/specs/
Für die momentane Ausstattung ja. Aber der VGA Ausgang des blauen Engel ist bunt. Soll ja beim Spectrum nicht S/W bleiben, oder?
Liebe Grüße Paul
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Benutzeravatar
schombi
User
Beiträge: 1862
Registriert: 05.09.2012, 09:45
Wohnort: Kreis KA

Re: Blauer Engel Diskussionen

Beitrag von schombi » 08.02.2016, 09:54

Sobald es ein Update für den Blauen Engel auf Spectrum mit Farbe gibt, rüste ich gerne auf einen Farbmonitor um :D

Antworten

Wer ist online?

Mitglieder in diesem Forum: Google [Bot], siggi und 1 Gast