(H4TH) VDrive Connection Card

ZX-Team Forum
Antworten
Benutzeravatar
tokabln
User
Beiträge: 1115
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

(H4TH) VDrive Connection Card

Beitrag von tokabln » 23.06.2017, 19:53

Sodele... ich mache hier mal einen eigenen Thread für die (H4TH) VDrive Connection Card auf, weil ich denke das die Diskussion nicht in den Backplane Thread sollte.

Basierend auf einer Information die ich von ZX-Heinz bekommen habe, habe ich mich heute mal beigemacht und eine erste Vergleichsmessung der H4TH Card ohne und mit BusDriver gemacht. Ich fange mal mit Heinz Hinweis an, der mir ein Oszilloskope Bild zum Pin#7 (CS) sowie zum Pin#15 (/OE) des 74xx367 zugesandt hatte um dieses mit meiner H4TH Card zu vergleichen.

Hier das Bild von Heinz:

VDrive Stefan Signale ZX-Heinz.JPG
Pin#7 (CS) & Pin15 (OE) am VDrive von Heinz
VDrive Stefan Signale ZX-Heinz.JPG (37.94 KiB) 795 mal betrachtet

und hier meine Vergleichsmessung an meiner H4TH Card am Bus Driver:

w BusDriver Pin#7 (CS) & Pin#15 (OE).jpg
Pin#7 (CS) & Pin15 (OE) mit BusDriver
w BusDriver Pin#7 (CS) & Pin#15 (OE).jpg (77.8 KiB) 795 mal betrachtet

Ich denke mal hier gibt es soweit nichts zu bemängeln.
Schauen wir uns nun das Geschehen an PIN#7 (CS) und Pin#11 (D7) an und vergleichen die Reaktion meiner H4TH Card auf READ Anfragen im ersten Bild ohne BusDriver

wo BusDriver Pin#7 (CS) & Pin#11 (D7).jpg
Pin#7 (CS) & Pin11 (D7) ohne BusDriver
wo BusDriver Pin#7 (CS) & Pin#11 (D7).jpg (83.47 KiB) 795 mal betrachtet
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
tokabln
User
Beiträge: 1115
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: (H4TH) VDrive Connection Card

Beitrag von tokabln » 23.06.2017, 19:56

Tja und hier nun gleiches Setup wie zuvor nur mit BusDriver.

w BusDriver Pin#7 (CS) & Pin#11 (D7).jpg
Pin#7 (CS) & Pin #11 (D7) mit BusDriver
w BusDriver Pin#7 (CS) & Pin#11 (D7).jpg (74.14 KiB) 793 mal betrachtet

Es gibt einen massiven Unterschied, denn ich erstmal eingrenzen muß. Da ich keinen 74HC367 in meinem Warenlager habe sondern hier 74LS367 eingesetzt habe, muß ich erstmal die HC Varianten bestellen um zu schauen ob das die Ursache sein könnte.

Andere Ideen oder Hinweise werden gerne angenommen
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
ZX-Heinz
User
Beiträge: 1334
Registriert: 05.12.2011, 14:45

Re: (H4TH) VDrive Connection Card

Beitrag von ZX-Heinz » 23.06.2017, 20:03

Hallo Torsten,
stell doch mal das aktuelle Schaltbild hier ein, damit man die "Pins" nachvollziehen kann.

PS: Beziehst Du Dich auf Stefans Schaltbild? Dann miss auch einmal an Pin12(SDI) vs. CS.

Vielleicht an Pin11 einen 10k-pullup-Wdst anhängen?
Zuletzt geändert von ZX-Heinz am 23.06.2017, 20:12, insgesamt 2-mal geändert.

Benutzeravatar
tokabln
User
Beiträge: 1115
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: (H4TH) VDrive Connection Card

Beitrag von tokabln » 23.06.2017, 20:10

Hallo Heinz,

ja kann ich machen... hier anbei:

Wobei es keine Unterschiede hinsichtlich der Bezeichnungen zu Stefan's Drive gibt, naja stimmt nicht ganz.
Ich habe mich an die Bezeichnung der Vinculum Dokumentation gehalten... nach dieser ist
Viculum Dokumentation:
RTS = SDO und RxD = SDI;

bei Stefan ist
RTS = SDI und RxD = SDO;
das ist aber egal, da das Pinout stimmt.

Die Karte läuft einwandfrei ohne den BusDriver. Ich muß also mal schauen was hier wie so zusammenwirkt, dass dieser Fehler auftritt.

Nachtrag:
Ich nehme gerade die Signale SDI / SDO zu CS auf und habe etliche Unterschiede mit und ohne BusDriver... ich dokumentiere alle Schritte und Scope Aufnahmen für eine spätere Analyse.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
Joachim
User
Beiträge: 898
Registriert: 06.11.2004, 20:21

Re: (H4TH) VDrive Connection Card

Beitrag von Joachim » 03.07.2017, 12:34

Hallo zusammen!
Ich habe versucht, mit dem ZX81NU und der VDrive-Connection-Card, vom USB-Stick zu lesen. Dazu habe ich Siggis Programm UFM-40K.P verwendet. Als Adresse habe ich $5F eingestellt. Man sieht an der flackernden Kontroll-LED im Stick einen Zugriff, allerdings bleibt die UFM-Maske leer - sprich: es wird kein Directory angezeigt. Drückt man dann irgendeine Taste, stürzt UFM ab. Mit anderen Adresseinstellungen ist es das Gleiche.
Hat schon jemand in dieser Kombination Erfolg gehabt?
Mit dem Forth für VDrive kann ich noch nicht testen, weil ich mir erst einen passenden Rechner aufbauen muss. Mit einem originalen ZX81 habe ich Probleme mit dem Einladen der Programme UFM-40K.p bzw. UFM-8k.p vom Stick im ZXblast. Dort werden derzeit nicht alle Programme auf dem Stick angezeigt. Und es scheint so, dass die nicht angezeigten (also nicht erkannten) Files auch nicht über eine Direkteingabe geladen werden können. Da ich keine andere Möglichkeit habe, Programme in den ZX81 zu bringen, fällt diese Testmöglichkeit derzeit aus.
Viele Grüße!
Joachim


ZX80, ZX81, ZX-Spectrum, ZX96, ZX2000, ZXmore, ZX81NU, Blauer Engel, AX81

Benutzeravatar
tokabln
User
Beiträge: 1115
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: (H4TH) VDrive Connection Card

Beitrag von tokabln » 03.07.2017, 12:53

Hallo Joachim, noch nicht in der Weise getestet aber es gibt da wohl einige zeitliche Abläufe, die im Vergleich Stefan's VDrive direkt am Zeddy vs. über H4TH Karte angeschlossen zu Problemen führen. Das sehe ich ja auch im Zusammenspiel Forth mit und ohne BusDriver. Ich bin da immer noch am evaluieren. Ein 10K Widerstand am Pin 11 vom 74LS367 gegen +5V macht das Signal zwar eindeutiger, aber es gibt hier zeitliche Unterschiede Stefan VDrive direkt am Zeddy vs. über die H4TH Karte. Ich bin da noch am probieren.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
siggi
User
Beiträge: 2161
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: (H4TH) VDrive Connection Card

Beitrag von siggi » 03.07.2017, 12:58

Joachim hat geschrieben:
03.07.2017, 12:34
Hallo zusammen!
Ich habe versucht, mit dem ZX81NU und der VDrive-Connection-Card, vom USB-Stick zu lesen. Dazu habe ich Siggis Programm UFM-40K.P verwendet. Als Adresse habe ich $5F eingestellt.
Dein Vorgehen verstehe ich nicht ganz: welchen Sinn macht die VDrive-Connection-Card an einem NU? Wenn Du den (richtigen: den mit dem NU-USB-Treiber!) UFM auf dem NU benutzt, greift der auf die interne(!) USB-Schnittstelle des NU zu. Wenn da parallel extern noch eine VDrive-Connection-Card dran hängt, fühlen sich 2 angesprochen (auch wenn kein VDRIVE im NU dran hängt: der Port wird trotzdem von der NU-Hardware decodiert!!!).
Man sieht an der flackernden Kontroll-LED im Stick einen Zugriff, allerdings bleibt die UFM-Maske leer - sprich: es wird kein Directory angezeigt. Drückt man dann irgendeine Taste, stürzt UFM ab. Mit anderen Adresseinstellungen ist es das Gleiche.
Na wenn da 2 gleichzeitig mit dem UFM quasseln: ?????
Hat schon jemand in dieser Kombination Erfolg gehabt?
Meine VDrive-Connection-Card habe ich noch nicht bestückt (es fehlen noch Bauteile und Zeit :wink: )

Gruß
Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Benutzeravatar
Joachim
User
Beiträge: 898
Registriert: 06.11.2004, 20:21

Re: (H4TH) VDrive Connection Card

Beitrag von Joachim » 03.07.2017, 13:23

Hallo Siggi,
der Test-ZX81NU hat kein Vdrive dran. Das ist der Umgebaute mit dem Mini-Mefisdos. Es war angedacht, Mefisdos zu verwenden und ggf. über eine PIO das Vdrive anzusprechen. Ich hätte da die Schnittstellen-ICs rausnehmen müssen!
Dann teste ich irgendwie anders. Mal seh'n wo noch ein Zeddy rumsteht.
Viele Grüße!
Joachim


ZX80, ZX81, ZX-Spectrum, ZX96, ZX2000, ZXmore, ZX81NU, Blauer Engel, AX81

Benutzeravatar
siggi
User
Beiträge: 2161
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: (H4TH) VDrive Connection Card

Beitrag von siggi » 03.07.2017, 13:51

Hallo Joachim
der UFM ist korrekt.
Aber "Schnittstellen-ICs" kannst Du da keine rausziehen: Ausgang Richtung NU-VDRIVE geht "minimalistisch" über das zentrale Latch, das auch Paging steuert (dessen Daten Richtung VDRIVE könnte man aber ins Leere laufen lassen). Und Eingang vom NU-VDRIVE ist über eine Diode direkt an den Datenbus. Die müsste man auslöten, damit die externen Daten durchkommen. Weiß aber im Moment nicht, welche Diode das ist (und der "Schaltplan" des NU ist an dieser Stelle ja falsch :( )

Gruß
Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Benutzeravatar
PokeMon
User
Beiträge: 4558
Registriert: 31.08.2011, 23:41

Re: (H4TH) VDrive Connection Card

Beitrag von PokeMon » 03.07.2017, 21:24

Joachim hat geschrieben:
03.07.2017, 12:34
Mit dem Forth für VDrive kann ich noch nicht testen, weil ich mir erst einen passenden Rechner aufbauen muss. Mit einem originalen ZX81 habe ich Probleme mit dem Einladen der Programme UFM-40K.p bzw. UFM-8k.p vom Stick im ZXblast. Dort werden derzeit nicht alle Programme auf dem Stick angezeigt. Und es scheint so, dass die nicht angezeigten (also nicht erkannten) Files auch nicht über eine Direkteingabe geladen werden können. Da ich keine andere Möglichkeit habe, Programme in den ZX81 zu bringen, fällt diese Testmöglichkeit derzeit aus.
Bist Du sicher, dass die Programme auf dem Stick sind ? Was im Zweifel immer gehen müsste, wäre Files vom Root Directory direkt zu laden. Eigentlich kann nur das Wechseln in ein Directory Probleme bereiten. Wenn ein Directory angezeigt wird, dann immer vollständig. Das macht der USB Stick selbst und überträgt das gelesene Directory als Datei zum ZXblast. Es könnte höchstens Probleme geben, wenn das Directory zu groß ist. So aus dem Kopf hat ein Eintrag 20 Bytes, also knapp 1500 Dateien in einem Verzeichnis würden das Memory Budget sprengen.
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
tokabln
User
Beiträge: 1115
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: (H4TH) VDrive Connection Card

Beitrag von tokabln » 15.07.2017, 16:07

Liebe H4TH VDrive User,

ein wirklich ganz ganz kurzer Zwischenbericht zum H4TH VDrive... das originale VDrive von Stefan funktioniert auch nicht am BusDriver... ich hab heute mal rasch ein Verbindungskabel VG64 auf Pin Leiste vom VDrive zusammengelötet und siehe da, es funktioniert alleine aber sowie der BusDriver dazwischen ist funktioniert es auch nicht mehr.

Damit liegt das Problem wohl eher am BusDriver und nicht an der H4TH VDrive Connection Card ZX81-BP005. Zum genauen messen werde ich erst die Tage kommen. Die KLEPS 3ST Klemmen sind mittlerweile da.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Antworten