Grünmonitor am ZX81

ZX-Team Forum
Benutzeravatar
ZX-Heinz
User
Beiträge: 1576
Registriert: 05.12.2011, 14:45

Re: Grünmonitor am ZX81

Beitrag von ZX-Heinz » 03.09.2018, 11:18

Paul hat geschrieben:
02.09.2018, 22:47
Ich habe einen Monitor der aussieht wie der von dir verlinkte. Der geht mit meinen ZX81 nicht weil er 60hz will und mit 50hz nicht klar kommt.
Mit 60hz Computern funktioniert er einwandfrei.
Da der ZX81 bei 60hz deutlich langsamer wird ist das für mich keine Alternative. Mit dem spectrum next läuft der wunderbar.
Liebe Grüße Paul
@Thomas F.: Pauls Bemerkungen klingen sehr plausibel. Sie würden auch erklären, warum Du nur entweder den oberen Teil oder den unteren Teil siehst, weil der Monitor beim Bildaufbau "zu schnell" ist (60Hz.) Da hilft dann auch Pokemons Video-Kärtchen nicht. Aber vielleicht könntest Du probehalber den ZX81 einmal auf 60Hz umschalten, auch wenn das für Paul keine Dauerlösung wäre. Das Umschalten auf 60Hz (USA) sollte durch Beschalten des Widerstandes R30=10Ohm am Pin22 der ULA möglich sein.

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 03.09.2018, 11:57

Ich hatte das so verstanden das Paul von dem Mini TFT beim Ebay Link sprach. Nicht von meinem Uralten Sanyo... Bin aber jetzt auch nicht sicher... Paul?

Ansonsten lege ich mir das Platinchen auf die Seite, kann man bestimmt mal brauchen.

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 03.09.2018, 12:55

Bin wieder zu hause und habe mal hinten auf den Monitor geguckt, ist ein 50Hz Bildschirm und könnte/sollte von daher von der Platine profitieren.

Genaue Bezeichnung ist: DM8112CX

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 03.09.2018, 16:12

Hat sich aber erst mal komplett erledigt, bei meinen ganzen Versuchen hat es jetzt einen Regler komplett zerbröselt und der Bildschrim ist wieder im Keller! Das werde ich bei Gelegenheit mal reparieren lassen, aber jetzt warte ich darauf das der erste Mini TFT hier eintrudelt...

Benutzeravatar
Paul
User
Beiträge: 2823
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: Grünmonitor am ZX81

Beitrag von Paul » 03.09.2018, 20:49

Ja, ich meinte den Mini TFT.
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 06.09.2018, 12:20

Erst mal das Wichtigste:

zx1.jpg
zx1.jpg (26.24 KiB) 965 mal betrachtet

Aber ein kleines Problem ist mir aufgefallen, das scheinbar in erster Linie bei der Verwendung des Graphic-Cursors auftritt.
Wenn ich "schwarze Leerzeichen" tippen möchte...

zx2.jpg
zx2.jpg (23.88 KiB) 965 mal betrachtet

...dann passiert beim 10. Mal Space drücken das hier:

zx3.jpg
zx3.jpg (25.68 KiB) 965 mal betrachtet

Das kriege ich auch nur wieder weg in dem ich Zeichen wieder lösche, 9 schwarze Leerzeichen sind ok und ich sehe meine Zeile wieder. Bei normalen Leerzeichen besteht das Problem nicht, da kann ich jede Menge eintippen ohne das das Bild "verschwindet".

Was hat es denn damit auf sich?

Gruß,
Thomas

Benutzeravatar
sbetamax
User
Beiträge: 494
Registriert: 04.03.2006, 22:01
Wohnort: Deutschland / Hessen / Nidda
Kontaktdaten:

Re: Grünmonitor am ZX81

Beitrag von sbetamax » 06.09.2018, 12:34

Hallo,
eine Möglichkeit wäre, das der Monitor die 10 Leerzeichn für den Vertikalen Syncronimpuls hällt. Und da dann daruf syncronisiert. Dafür siehst du oben dann den eigentlichen Sync als schwarzen Strich.
Gruß Stephan
_______________
ZX80 (nachbau), ZX81, ZX 2000, ZX NU, IQ8300, ZX Spectrum, ZX Spectrum plus, ZX Spectrum 128, Harlequin, C64

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 06.09.2018, 13:42

Ja, könnte sein. Wenn ich z.B. inverse Buchstaben nehme, dann kann ich immerhin 26 Zeichen tippen bis dieser Fall eintritt. Könnte also sein dass das hier noch nicht mein letzter Bildschirm für den Zeddy ist. Aber fürs erste gehts ja.

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 07.09.2018, 05:38

Aber halb so wild, in so einem Fall muss ich dann nur "blind" weiter tippen, nach <Enter> erscheint die Zeile dann normal in der Liste oben. Wenn man mehr Zeilen geschrieben hat, ist es auch so, dass der Schwarze Streifen weiter zur Mitte hin ist, und man die Engabezeile oben am Bildschirm hat. Dann sieht man eh wieder was man tippt... ;) Der Bildschrim ist sicher nicht die Beste Empfehlung, z.B. muss ich den auch zum Laden und Speichern auf Kassette ausschalten. Der verliert nämlich immer den Kontakt zum Zeddy und kommt dann oft auch nicht mehr zurück.

Gruß,
Thomas

Benutzeravatar
siggi
User
Beiträge: 2450
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: Grünmonitor am ZX81

Beitrag von siggi » 07.09.2018, 10:15

Thomas F. hat geschrieben:
07.09.2018, 05:38
Der Bildschrim ist sicher nicht die Beste Empfehlung, z.B. muss ich den auch zum Laden und Speichern auf Kassette ausschalten. Der verliert nämlich immer den Kontakt zum Zeddy und kommt dann oft auch nicht mehr zurück.
Moin.
Und genau zur Behebung dieses Problems hat ja Pokemon einen kleinen Chip auf sein Video-Platinchen gesetzt, der während "Abwesenheit" des Zeddy-Bildes autonom SYNC-Signale generiert, die das Display "am Leben erhalten". Hier auf dem unteren Bild ist der Chip zu sehen:

viewtopic.php?f=2&t=2724#p37101

Gruß
Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Datenkraken bitte nicht füttern!

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 07.09.2018, 17:05

Danke dir! Da trifft es sich ja gut das ich gestern sowas aus dem Briefkasten gezogen habe. Dann werde ich mich am Wochenende mal damit näher beschäftigen.

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 13.09.2018, 20:36

Ich habe mich heute Abend mal dran gesetzt. Hat funktioniert, inkl. die inverse Darstellung! Sicherheitshalber habe ich eine Cinchbuchse lose angelötet um nicht das bereits Vorhandene auszubauen... Sicher ist sicher.

Aufgefallen ist mir aber dass die bisher genutzte Lautstärke zum Laden von Kassette jetzt nicht mehr funktioniert. Kann das sein, dass sich das durch einen anderen Video-Mod verändert? Erst war es so dass das "K" viel zu schnell wieder da war, oder gar nicht zurück kam... Nachdem ich dann ein paar Stufen leiser gestellt habe, ging es!

Die Probleme mit den 10 Graphic Leerzeichen sind damit auf jeden Fall auch behoben.

Viele Grüße,
Thomas

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 13.10.2018, 15:38

Ne Kleinigkeit hänge ich hier noch mal dran, möchte nicht für jeden meiner Fauxpas einen neuen Thread starten... ;)

Irgendetwas ist vorgefallen das der Kassettenrekorder stark brummt wenn ich den Videostecker an den ZX81 anschließe... Die Videoausgabe ist weiterhin sehr gut, aber so kann natürlich nicht mehr von Tape geladen werden. Wegen dem neuen ZXpand+ ist das zwar erst mal egal, aber bei Gelegenheit würde ich das gerne wieder beheben.

Danke,
Thomas

Thomas F.
User
Beiträge: 51
Registriert: 03.04.2015, 10:19

Re: Grünmonitor am ZX81

Beitrag von Thomas F. » 26.10.2018, 20:47

Grüß Euch,

das brummen ist zwar nicht weg, aber trotzdem läuft jetzt alles (wieder). Laden von Kassette funktioniert einwandfrei, und ich habe gelernt dass man den typischen "tapesound" gar nicht zwingend mithören muss. Zumindest wenn sich der Lautsprecher am Rekorder abschalten lässt...

Der ZX8-CCB hat jetzt einen Schalter bekommen. Zwar tendiere ich stark zur Inversen Darstellung, aber jetzt die Möglichkeit zu haben bequem auf den Standard Modus zu wechseln gefällt mir sehr! Beeindruckend finde ich das absolut störungsfreie Umschalten.

Nachdem jetzt alles läuft kann ich mich mal um die Software kümmern. :)

Gruß,
Thomas

Antworten