"Sauschnelles" neues ZX81 ROM "Big Bang" von ZSOLT

ZX-Team Forum
Benutzeravatar
tokabln
User
Beiträge: 1455
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: "Sauschnelles" neues ZX81 ROM "Big Bang" von ZSOLT

Beitrag von tokabln » 05.10.2018, 11:42

Hallo siggi,

das ist natürlich toll... es ist schon irgendwie verrückt...

- bei Heinz funktioniert die APU am Speccy,
- bei Dir das BigBang Eprom im ZX81 mit H4TH Adapter...

und bei mir... nichts davon... jetzt habe ich meinen Brenner im Verdacht... ich werde nachher mal das EPROM im TL866 brennen... bisher habe ich meinen Dataman S4 verwendet... aber vielleicht hat der ja eine Macke... obwohl er die gebrannten EPROMs und deren Code als korrekt verifiziert.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
ZX-Heinz
User
Beiträge: 1563
Registriert: 05.12.2011, 14:45

Re: "Sauschnelles" neues ZX81 ROM "Big Bang" von ZSOLT

Beitrag von ZX-Heinz » 05.10.2018, 12:02

Die Leitung A12-A12 ist auf der Sinclair-Leiterplatte schon vorhanden. Lass die auf Deinem Adapter doch mal weg.

Benutzeravatar
tokabln
User
Beiträge: 1455
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: "Sauschnelles" neues ZX81 ROM "Big Bang" von ZSOLT

Beitrag von tokabln » 05.10.2018, 12:16

Na toll... der Dataman S4 hat ein Problem... das ZX81X2 EPROM im TL866 eingelesen... keine Daten drin.

Ein neues EPROM gebrannt während das alte im UV Licht liegt... und Bingo... es läuft.

Damit sind wohl dann auch die Speccy Probleme gelöst... ich könnte heulen über soviel verschwendete Zeit und den Eigenzweifeln... :twisted:
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Kai
User
Beiträge: 428
Registriert: 19.04.2005, 20:46

Re: "Sauschnelles" neues ZX81 ROM "Big Bang" von ZSOLT

Beitrag von Kai » 07.10.2018, 10:32

Ich hatte auch schon EPROMs, da lief das Verify noch durch und 1 Minute später hatten die erste Bitfehler. Manche alte Typen kommen mit dem schnellen Algorithmus nicht klar und wollen wirklich hart mit 50ms gebrannt werden. Da helfen zwar auch mehrere Brenndurchgänge, aber sicher ist sowas dann nicht. Ich sortiere solche EPROMs aus.

Benutzeravatar
tokabln
User
Beiträge: 1455
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: "Sauschnelles" neues ZX81 ROM "Big Bang" von ZSOLT

Beitrag von tokabln » 07.10.2018, 11:07

Guten Morgen Kai,

ja das ist wohl so... aber der Dataman ist ein älterer sehr konservativer EPROM Brenner... und ich ahtte es wie auch immer geschafft eine Einstellung zu verändern, die letztlich zu dem Desaster geführt hat. Jetzt geht alles wieder und ich bin froh das dies so ist, zumal der TL866 bei älteren EPROMs keinerlei Algorithmen anbietet.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Thomas F.
User
Beiträge: 50
Registriert: 03.04.2015, 10:19

Re: "Sauschnelles" neues ZX81 ROM "Big Bang" von ZSOLT

Beitrag von Thomas F. » 16.10.2018, 19:04

Hallo,

hat das hier schon jemand im eightyOne zur Zusammenarbeit mit ZXpand überreden können? Einfach so ging das ja nicht, ZXpand war dann nicht mehr auswählbar. Wäre natürlich auch für die echte Hardware dann später interessant.

Gruß,
Thomas

Benutzeravatar
siggi
User
Beiträge: 2419
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: "Sauschnelles" neues ZX81 ROM "Big Bang" von ZSOLT

Beitrag von siggi » 16.10.2018, 20:40

Das ZxPand-Rom selbst ist massiv gepatcht, um die ZxPand-Funktionalität zu haben (LOAD/SAVE, nix LPRINT/COPY/LLIST, Zeichengenerator fehlt, ..). Diese Patches muß man (Charlie :wink: ) ins ZX81x2-Rom einbringen, damit das läuft ...

Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Datenkraken bitte nicht füttern!

Antworten