ZON-X Soundmodul - wieder ein Projekt

ZX-Team Forum
Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 20.10.2011, 08:36

Hallo Jens,

danke für deine Antwort!

Ich glaube ich werde den Stecker jetzt doch drehen, so dass die Elektronik nicht in Richtung des Steckers sondern auf der anderen Seite Montiert wird, so wie beim zxPand.

@Siggi:

Ich denke, dass im schlimmsten Fall 2 zx96 slots dadurch verloren gehen. Ist das richtig? Sofern man die Platine nicht sockelt, müsste es doch gerade so passen?

Grüße

Sascha

Benutzeravatar
Paul
User
Beiträge: 2849
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von Paul » 20.10.2011, 09:00

Jens hat geschrieben:Ich besitzte übrigends ein Original-ZonX und auch das neue AY-ZXPand aus England - beide klingen tatsächlich gleich :lol:
Hi Jens, das ist aber schade. Ist das jetzt ein hervorragendes Original-ZonX oder ein eher bescheidener Verstärker über den du das AY-ZXPand hörst? Gerade wegen der bescheidenen Tonqualität des Verstärkers im Original-ZonX hat SirMorris ja auf den eingebauten Verstärker verzichtet und uns zum Kauf hochwertiger PC Lautsprecher zu 3,99€ gezwungen :lol:
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Benutzeravatar
siggi
User
Beiträge: 2471
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von siggi » 20.10.2011, 09:05

Jens hat geschrieben: Ich besitzte übrigends ein Original-ZonX und auch das neue AY-ZXPand aus England - beide klingen tatsächlich gleich :lol:

Liebe Grüße
Jens
Bei Ballerspielen mit Puff-Bäng-Zoing dürften beide noch ähnlich klingen. Bei guter Musik aber nicht mehr (*) :mrgreen:

Siggi

Edit: (*) außer man hat ähnlich "hochwertige" Lautsprecher angeschlossen, wie in der Original-Box verwendet sind :roll:

Benutzeravatar
Paul
User
Beiträge: 2849
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von Paul » 20.10.2011, 09:18

sascha2000 hat geschrieben:Ich glaube ich werde den Stecker jetzt doch drehen, so dass die Elektronik nicht in Richtung des Steckers sondern auf der anderen Seite Montiert wird, so wie beim zxPand.
Bei gedrehtem Stecker, wird die Audiobuchse erreichbar sein wenn man das Ganze in ein Memotech Gehäuse packt? Ist er dann also rechts und nicht mehr links?
Auf der linken Seite (jeweils vom ZX81 aus gesehen bei Normalbetrieb) bleibt dann ja noch Platz. Den könnte man schön mit eigenen Zusatzplatinen nutzen. Sind noch GAL Pins frei (zum frei verdrahten, keine Designänderung gemeint)?
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Benutzeravatar
siggi
User
Beiträge: 2471
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von siggi » 20.10.2011, 09:33

sascha2000 hat geschrieben: Ich denke, dass im schlimmsten Fall 2 zx96 slots dadurch verloren gehen. Ist das richtig? Sofern man die Platine nicht sockelt, müsste es doch gerade so passen?
Ja, das wird wohl 2 Slots kosten. Aber ungesockelt wird nicht helfen, denn normalerweise ist die Unterseite nicht bestückt und entsprechend wenig Abstand (z.B. zur Seitenwand) vorgesehen. Siehe z. B.

http://www.fischerkai.de/zxteam/zx96_d.htm
http://www.fischerkai.de/zxteam/pics.htm

Aber wenn es halt nicht anders geht ...

Gruß
Siggi

Benutzeravatar
Jens
User
Beiträge: 1157
Registriert: 23.08.2005, 13:31
Wohnort: D-31582 Nienburg/Weser

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von Jens » 20.10.2011, 09:35

Jungs!

Ihr habt natürlich vollkommen Recht!!! Das AY klingt in Stereo besser als meine eigene Stereoanlage - und den C64 mit seinem SID schmeiße ich jetzt weg... :roll:

Im Ernst: tolle Arbeit - ich bin gespannt...

@Paul: meine Boxen haben nix gekostet: sind vom Sperrmüll - was die Leute so alles wegwerfen... tztztz...

Gruß
Jens
Der ZX81 rechnet mit allem, nur nicht mit seinem Besitzer...
Neues aus der KI-Welt... Die Automate kann sich selbst essen.

Benutzeravatar
PokeMon
User
Beiträge: 4706
Registriert: 31.08.2011, 23:41

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von PokeMon » 20.10.2011, 11:14

Jens hat geschrieben: Ungesockelt geht garnicht - da habe ich dann lieber etwas mehr Abstand.
Bei mir gilt genau das Gegenteil. :mrgreen:
Ich sockel noch nicht mal Prototypen.
Ausser es ist wirklich ein extrem teures Bauteil, allerdings werden die komplexen Bauteile häufig in SMD Bauweise (QFP bzw, QFN Gehäuse) gefertigt, deren Preis für einen (schweineteuren) Sockel den des IC's oftmals übersteigt. Ansonsten sterben nach meiner Erfahrung eingelötete Bauteile äußerst selten, falls doch ein zu kurzes Leben eines Bausteins hervortritt liegt es zu 99% an Designfehlern der Schaltung (z.B. Kurzschlussfestigkeit von Ausgängen oder zu starke Belastung von Digitalausgängen mit niederohmigen Widerständen oder größeren Kondensatoren, Elkos, etc.). :wink:

Aber wie so Vieles im Leben Geschmacksfrage.

@Sascha
Du solltest bei Deiner Platine bedenken, dass nicht alle verfügbaren Stecker so lange Wirestifte haben (werden). Du hast den jetzt mit Abstand zur Platine eingelötet und nur aus diesem Grund passen die IC's und Kondensatoren an den Stellen wo Du sie platziert hast. Musste ich bei meinem aktuellen Prototypen auch feststellen, dass eine kleine Platinenfläche momentan nicht nutzbar ist, weil sonst die Platine mit dem Stecker nicht ganz auf den Zeddy draufpaßt. Habe ihn aber auch direkt eingelötet (nicht auf Abstand).
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 20.10.2011, 23:54

Hallo!

@Paul:

>Bei gedrehtem Stecker, wird die Audiobuchse erreichbar sein wenn man das Ganze in ein Memotech Gehäuse packt?
>Ist er dann also rechts und nicht mehr links?

Wo würdest du den Stecker gerne haben?

Da die Platine aufgrund der VG64 Kompatibilität ohnehin rechts rausguckt könnte ich den Anschluss gleich auf die rechte Seite machen.

Wobei .... ich weis noch nicht genau wie ich es machen werde. Evtl. mache ich die Karte einfach etwas höher. Dann passt die Karte natürlich nicht mehr in ein Memotech Gehäuse.....

>Auf der linken Seite (jeweils vom ZX81 aus gesehen bei Normalbetrieb) bleibt dann ja noch Platz. Den könnte man schön mit eigenen Zusatzplatinen nutzen. Sind noch GAL Pins frei (zum frei verdrahten, keine Designänderung gemeint)?

Ja Pin 12, 13, 14, 15 sind noch frei. Ich habe diese Pins auf die Streckerleiste gelegt, damit man mit diesen experimentieren .....

@Siggi
>Aber wenn es halt nicht anders geht ...
Mal abwarten. ggf. Mache ich das Teil höher ....

@Pokemon
>Du solltest bei Deiner Platine bedenken, dass nicht alle verfügbaren Stecker so lange Wirestifte haben (werden).

Ja, diese "Licht" ist mir heute beim Testen der Platine (habe ich kurz vor der Arbeit gemacht) auch aufgegangen. Die stehende Version war einfach ein schnellschuss, ich habe da mit zu wenig "Hirn" gearbeitet.

>Du hast den jetzt mit Abstand zur Platine eingelötet und nur aus diesem Grund passen die IC's und Kondensatoren an den Stellen wo Du sie platziert hast.
Ja richtig. Ich werde alle Bauteile weiter nach "oben" verlegen müssen.

>Musste ich bei meinem aktuellen Prototypen auch feststellen, dass eine kleine Platinenfläche momentan nicht nutzbar ist, weil sonst die Platine mit dem Stecker nicht ganz auf den Zeddy draufpaßt. Habe ihn aber auch direkt eingelötet (nicht auf Abstand).

Tückisch war, dass ich die stehende Platine zuerst an der Memotech 16k Speichererweiterung angesteckt hatte. Da gab es gar keine Probleme. Erst als ich die Platine mit dem zxpand betreiben wollte, musste ich diese direkt in den Zeddy einstecken .... da kam dann das Problem zum Vorschein ...... Kacke!

@Siggi & Paul
Ich schau jetzt, dass ich die Platinen Versandfertig mache. Leider habe ich keine Widerstände und keine Koppelkondensatoren mehr. Die müsstet ihr euch "organisieren". YM2149, GAL usw. liegen bei.

Viele Grüße
Sascha

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 21.10.2011, 00:55

@Siggi und Paul

Pakete sind fertig. Gehen Morgen raus.

Anbei noch der Bestückungsplan:
Bestückung.png
Bestückung.png (59.46 KiB) 7820 mal betrachtet
Viele Grüße

Sascha

Benutzeravatar
siggi
User
Beiträge: 2471
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von siggi » 22.10.2011, 15:16

Isch habe fertig :D

Mein Platinchen ist bestückt und läuft. Zwar hatte ich keine 1K6 Widerstände auf Lager, aber 1K5 tun's auch. Und alle Bohrungen haben gepaßt :mrgreen:

Und so sieht die ZX96-Variante aus:
AY-ZX96_1024x768.JPG
AY-ZX96_1024x768.JPG (154.8 KiB) 7797 mal betrachtet
Nun muß ich sie nur noch im Merker-Zeddy testen, weil da auch /BUSCS benötigt wird.

Siggi

Nachtrag: Es macht auch Spaß, wenn man da die 100W-Aktivboxen dranhängt, die auch die Bässe deutlich besser bringen als 3-Euro-PC-Lautsprecher. Das freut dann auch den Nachbarn :mrgreen:

Benutzeravatar
Paul
User
Beiträge: 2849
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von Paul » 22.10.2011, 15:47

Dem Bild entnehme ich das auch Tantals gehen. Die habe ich vorrätig. Mist das ich das Päckchen nicht annehmen konnte. Bin gerade auf der Fähre nach England. Ist aber auch schön hier :D
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 22.10.2011, 19:01

Hallo Siggi,

Wow das ging flott! Respekt!

Das Signal /BUCS konnte ich leider nie testen. Ich will meine Hand für den GAL Code mal nicht ins Feuer legen .....

Lass mich bitte wissen, wenn du die Karte am zx96 Bus geprüft hast.

Viele Grüße

Sascha

Benutzeravatar
siggi
User
Beiträge: 2471
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von siggi » 23.10.2011, 13:30

Hallo Sascha,
so, der Test mit dem ZX96 (bzw. meinem Merker-Zeddy) ist erfolgreich verlaufen: die Musik kommt da auch. :mrgreen:

Aber es war sehr mühsam, dies zu erreichen, denn da gibt es ein Problemchen: die Adresse der ZON-BOX kollidiert leider mit der Adresse meines MMC-Interfaces (siehe http://tlienhard.com/zx81/HighspeedMMC.pdf). Und so konnte ich AYDEMO nicht von MMC laden, sondern mußte 3 Cassettenrecorder reanimieren, bis ich das Programm schließlich geladen hatte :(

Ein Lösung dieses Problemchens hätte ich aber: da ein Lesen der AY-Register nur über die hohen Adressen DF/CF erfolgt, könnte man die Adreßdecodierung im GAL so ändern, daß bei Lesezugriffen auf die niederen Adressen 0F/1F der AY/YM nicht aktiviert wird (nur bei Schreibzugriffen). Dann müßten sich auch MMC-Interface und AY/YM parallel betreiben lassen.

Zwar blinken die CARDSELECT-Leds meines MMC-Interfaces im Takt der Musik, wenn der AY angesprochen wird. Aber da sollte nichts passieren, da die Musik vermutlich nicht mit MMC-Kommandos zusammenpaßt, sodaß die MMCs da weghören würden.
Und bei Benutzung der MMC würde schlimmstenfalls der AY losheulen, wenn er MMC-Kommandos in seine Register schreibt. Aber da kann man die Boxen abstellen..

Kannst Du vielleicht mal das GAL so ändern, wie oben beschrieben? Oder schicke mal die GAL-Gleichungen (GAL kann ich selbst brennen).

Gruß
Siggi

@Joachim, Kai, andere ZX96-er: sind in euren ZX96ern noch weitere Adreßprobleme zu erwarten?

Benutzeravatar
Joachim
User
Beiträge: 1083
Registriert: 06.11.2004, 20:21

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von Joachim » 23.10.2011, 17:20

Hallo Sascha!
Auch ich bin mit MrX fertig und voll zufrieden. Alles hat auf Anhieb geklappt. Der Sound ist fantastisch!!!
Das Anlöten der Elkos ist tatsächlich nicht stabil. Bei mir löste sich ein Lötauge ab. Mit einem dünnen Draht von untern durch gings. Die Bohrungen für den VG64-Stecker sind etwas knapp und sollten größer werden. Der Abstand von 5 mm (Lötauge VG64-Stecker zum Platinenrand) wurde nicht eingehalten, so dass es etwas knapp zu ging. Mit etwas biegen der Pins ging es dann.
Das BUS-CS-Signal funktioniert offensichtlich tadellos. Bei mir gab es bisher zum Glück noch keine Adressenkollision. Am Sound kann man nichts verbessern.
Die Platine paßte problemlos in das Bussystem. Auch ist genügend Platz für die Schienenführung.

Glückwunsch zu diesem gelungenen Projekt und vielen Dank, dass ich bei den Testern sein durfte.

viele Grüße
Joachim
Dateianhänge
Eingebauter MrX.jpg
Eingebauter MrX.jpg (273.58 KiB) 7757 mal betrachtet
MrX Bestückungsseite.jpg
MrX Bestückungsseite.jpg (419.32 KiB) 7757 mal betrachtet
Viele Grüße!
Joachim


ZX80, ZX81, ZX-Spectrum, ZX96, ZX2000, ZXmore, ZX81NU, Blauer Engel, AX81

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 23.10.2011, 21:30

Hallo Joachim,

vielen Dank für deine Unterstützung beim testen der MrX Soundkarte und für das viele Lob!

>Das Anlöten der Elkos ist tatsächlich nicht stabil. Bei mir löste sich ein Lötauge ab.
Ja ist schief gegangen beim Layouten. Die nächste Version wird 0,8mm Bohrlöcher haben und keine 0,6mm wie beim Prototyp.

>Der Abstand von 5 mm (Lötauge VG64-Stecker zum Platinenrand) wurde nicht eingehalten
Ja sind so ca. 5,5 - 6mm geworden. Sollte bei der Karte von Siggi bereits behoben sein.
@Siggi, kannst du das bestätigen?

... Und die Bohrungen habe ich bereits im Layout auf 1mm vergrößert.

>Glückwunsch zu diesem gelungenen Projekt
Vielen Dank Joachim! Ich wünsche dir viel Spass mit der MrX Karte! Sollte der eine oder andere Mangel auftreten, bitte mir melden!

Viele Grüße

Sascha
Zuletzt geändert von sascha2000 am 24.10.2011, 17:09, insgesamt 1-mal geändert.

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 23.10.2011, 21:41

Hallo Siggi,

vielen Dank fürs testen und den damit verbundenen Aufwand!

Anbei die letzte Version der Gal Gleichungen:

Gal16V8
#
#
Clk A1 A2 A3 IRQ WR A6 A7 A5 GND
/OE NC NC NC NC BUCS BC1 BDIR Q0 VCC
#
Q0 := /Q0
IF(VCC)
BDIR = /WR * /IRQ * A1 * A2 * A3 * /A5 * A6 * A7 + /WR * /IRQ * A1 * A2 * A3 * /A5 * /A6 * /A7
IF(VCC)
BC1 = /IRQ * A1 * A2 * A3 * /A5 * A6 * A7
BUCS = /BC1 * /BDIR


>Ein Lösung dieses Problemchens hätte ich aber: da ein Lesen der AY-Register nur über die hohen Adressen DF/CF erfolgt
richtig

>könnte man die Adreßdecodierung im GAL so ändern, daß bei Lesezugriffen auf die niederen Adressen 0F/1F der AY/YM nicht aktiviert wird
>(nur bei Schreibzugriffen). Dann müßten sich auch MMC-Interface und AY/YM parallel betreiben lassen.

Bei Lesezugriffen ist WR = 1 und somit /WR=0. Damit bleibt BDIR=0, also auf Read. BC1 ist 0 bei Lesezugriffen auf 0F/1F. Somit ist der ym inaktiv.

Bei Lesezugriffen werden nur die Adressen DF/CF akzeptiert...

Eventuell liegt das Problem woanders?

Viele Grüße

Sascha


Viele Grüße

Sascha

Benutzeravatar
siggi
User
Beiträge: 2471
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von siggi » 24.10.2011, 09:07

Hallo Sascha,
so auf den ersten Blick sehen die Gleichungen ok aus. Da muß ich nun wohl den Graf Oszi zu Rate ziehen und gucken, was da so passiert.
Könntest Du den aktuellen Schaltplan auch mal posten (wird ja auch benötigt, wenn man ein Huckepackplatinchen draufbasteln will).

Gruß
Siggi

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 24.10.2011, 09:55

Hallo Siggi,

den Schaltplan kann ich dir erst heute Nacht zukommen lassen. Ich bin bis 23:00Uhr auf Achse.

Der Schaltplan ist jedoch nicht besonders hübsch. Ich habe da wenig mühen darauf verwendet.


Und ja .... wenn ich mir die Bilder von Joachim anschaue..... vom Bus .... dann könnte ein gedrehter Stecker durchaus funktionieren. Man könnte zur Isolation etwas Pappe oder vergleichbares verwenden. Was meinst du?

Das derzeitige Layout kann ich recht problemlos so abändern, dass die Chips alle ganz Oben positioniert sind. Mit dem Slotstecker von Paul ist das dann auch gar kein Problem.
Nur der Slotstecker von Reichelt, der für voll bestückte Platinen (ROHS läßt grüßen) zu verwenden ist, geht dann gar nicht.

Die Platine höher machen wäre natürlich möglich, dann hat diese aber über die ganze höhe des ZX81 eine leere Fläche. Ist auch nicht so der bringer .....

Was meinst du, sollen wir die nächsten Prototypen mit gedrehtem Stecker mal testen? Kannst du den abstand auf dem Bus von den Platinenoberseiten messen?


Viele Grüße

Sascha

Benutzeravatar
siggi
User
Beiträge: 2471
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von siggi » 24.10.2011, 11:00

Hallo Sascha,
die Leiterplatten sind im Abstand von 4 TE (http://de.wikipedia.org/wiki/Baugruppentr%C3%A4ger) montiert, also ca. 20 mm. Bei "verkehrter" Bestückung müßte man vermutlich alle Bauteile ungesockelt einlöten, daß man da hin käme. Und mit "Huckepack" ist dann nix mehr ...

Andere Idee:
Die Platine so lassen, wie sie ist, nur etwas länger (bzw. höher bei Stehend) machen. Da dann die 46 Löcher/Pins für den Slot-Stecker unterbringen, der dann aber von der anderen Seite bestückt wird. Das gibt zwar ziemlich Gewurschtel beim Layout, da VG64 und Slotstecker "über Kreuz" angeschlossen werden, aber das Platzproblem wäre dann behoben: bei Bestückung mit VG-64 sind die Bauteile auf der Seite des Steckers, bei Bestückung mit Slotstecker (am anderen Ende) sind die Bauteile auf der Rückseite ...

[EDIT] Upps, das war ein Denkfehler: wenn der Slotstecker auf die Rückseite wandert, muß nichts "über Kreuz" angeschlossen werden (nur "vordere Reihe" und "hintere Reihe" wird getauscht). Also wird das Layout nicht viel komplizierter, weil ja nur die benötigten Pins (nicht alle) bei beiden Steckern verbunden sein müssen.


Gruß
Siggi

PS: Die 3,5 mm Buchse müßte noch neben dem Slotstecker sitzen (für ZX96-Anschluß)
PS/2: Die Anschlüsse für die Huckepackplatine würde ich mindestens 2-reihig machen (oder 2 Stecker): wäre mechanisch stabiler (keine verbogenen Pins) und braucht weniger Breite
Zuletzt geändert von siggi am 24.10.2011, 23:12, insgesamt 1-mal geändert.

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 24.10.2011, 11:22

>Die Anschlüsse für die Huckepackplatine würde ich mindestens 2-reihig machen (oder 2 Stecker): wäre mechanisch stabiler (keine verbogenen Pins) und braucht weniger Breite

Ja habe ich gestern Abend bereits so gemacht, da die Chips nach oben gewandert sind und die Steckerleiste in der Mitte für den Router hinderlich war. Um das Routing zu erleichtern habe ich dann zum Teil noch die Pins getauscht.

Nun gut ... kann das auch heute Abend mal als Vorschlag einstellen.

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 24.10.2011, 22:50

Hallo Siggi,

hier der Schaltplan.

Analog:
Analogteil.png
Analogteil.png (53.91 KiB) 7691 mal betrachtet
Digital:
digitalteil.png
digitalteil.png (59.31 KiB) 7691 mal betrachtet
Buchse (nur 30 Pins im Layout verwendet, einreihig):
Buchsenleiste.png
Buchsenleiste.png (45.46 KiB) 7691 mal betrachtet
Ich hoffe, dass dir diese zugegeben nicht sehr schönen "Pläne" weiterhelfen ...

Viele Grüße

Sascha

Benutzeravatar
siggi
User
Beiträge: 2471
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von siggi » 24.10.2011, 23:15

Die helfen sicher weiter, auch wenn die Widerstände( 470 Ohm laut Schaltplan) nun 1k (laut Bestückungsplan) sind.

Danke
Siggi

Benutzeravatar
siggi
User
Beiträge: 2471
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von siggi » 24.10.2011, 23:29

sascha2000 hat geschrieben: >Der Abstand von 5 mm (Lötauge VG64-Stecker zum Platinenrand) wurde nicht eingehalten
Ja sind so ca. 5,5 - 6mm geworden. Sollte bei der Karte von Siggi bereits behoben sein.
@Siggi, kannst du das bestätigen?
Ja: VG64-Stecker sitzt mittig auf der Platine und diese läßt sich ohne Unterstützung eines Wagenhebers in den ZX96-Bus-Stecker drücken :lol:

Siggi

Benutzeravatar
sascha2000
User
Beiträge: 468
Registriert: 05.05.2011, 11:58
Wohnort: Zwischen Reutlingen und Tübingen

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von sascha2000 » 25.10.2011, 08:21

>Die helfen sicher weiter, auch wenn die Widerstände( 470 Ohm laut Schaltplan) nun 1k (laut Bestückungsplan) sind.

Dir entgeht aber auch gar nichts :oops: :oops: :oops: :oops: :oops:


Bei der Platine werde ich jetzt folgendermaßen vorgehen.

* Die stehende Variante mache ich jetzt 6mm höher.
* Die Chips werden ganz oben angeordnet.
* Der Stecker für Daughterboards kommt in die Mitte.
* Die Widerstände und Kondensatoren werden unten angeordnet.
* Der Stecker wird nicht gedreht.

--> Rs und Cs kann man auf der Platine auf der Vor- oder -Rückseite verlöten. Die Stören dann beim Reichelt Slotstecker nicht.
--> Die Chips sind "über" dem zx81 Gehäuse.
--> Der Aufbau funktioniert mit Pauls Slotstecker, Reichelt Slotstecker sowie vg64 Stecker.
--> Der Einbau in ein Memotech Gehäuse ist nicht mehr möglich.

Eventuell mache ich noch ein Gehäuse dazu .... mal sehen ......

Viele Grüße

Sascha

Benutzeravatar
Paul
User
Beiträge: 2849
Registriert: 10.03.2010, 12:01
Wohnort: Germanys west end

Re: ZON-X Soundmodul - wieder ein Projekt

Beitrag von Paul » 26.10.2011, 12:40

Paul hat geschrieben:Dem Bild entnehme ich das auch Tantals gehen. Die habe ich vorrätig. Mist das ich das Päckchen nicht annehmen konnte. Bin gerade auf der Fähre nach England. Ist aber auch schön hier :D
Man bin ich froh mit dieser harmlosen Frage nicht das gleiche ausgelöst zu haben wie hier:
http://www.mikrocontroller.net/topic/104746
Das sind ja eher Glaubenskriege :shock:
Bei mir ist der Klirrfaktor immer stark abnehmend wenn der Inhalt der Whiskygläser weniger wird, strebt quasi gegen Null. Aber man kann ja nachfüllen :D
Ich mag hohe Klirrfaktoren :wink:
Theoretisch ist zwischen Theorie und Praxis kein Unterschied.
Praktisch allerdings wohl.

Antworten