ERLEDIGT: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

SPC Club Forum
Antworten
HarleyStone
User
Beiträge: 5
Registriert: 01.02.2019, 15:27

ERLEDIGT: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

Beitrag von HarleyStone » 01.02.2019, 16:20

Hallo,

hab hier noch einen alten +2A (Mainboard Issue 2).

Bei diesem Gerät habe ich die Elkos ersetzt (4 x 1µF +3 x 100uf), da das Teil schon vorher ein paar Probleme mit der Videodarstellung hatte. Die Elkos wurden natürlich richtig eingelötet (Polung). Löte auch oft, deshalb kann ich nach mehrmaligem Überprüfen hier einen Fehler "fast" ausschließen.

Nach dem Ersetzen hab ich nun nach dem Einschalten einen schwarzen Bildschirm und nen weißen Rand. Das Ganze ist mit einem kaum hörbaren Summen unterlegt. Nach ca. 5 Sekunden verschwindet der weiße Rand und der Bildschirm ist nur noch schwarz. Das Summen verschwindet auch. Die Power-LED geht ganz normal an und leuchtet auch durchgehend. Hatte mal im Net recherchiert und das Ganze scheint auf einen oder mehrere defekte RAM Bausteine hinzudeuten. Das Eigenartige ist aber, daß der schwarze Bildschirm mit weißen Rand nur ein paar Sekunden da ist und nicht konstant (so wie es bei nem defekten RAM ist).

Wer weiß mehr und hat evtl. ein paar Tipps?

Vielen Dank.
Zuletzt geändert von HarleyStone am 02.02.2019, 12:24, insgesamt 1-mal geändert.

Benutzeravatar
tokabln
User
Beiträge: 1525
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

Beitrag von tokabln » 01.02.2019, 16:57

Moin, Moin,

wie Du schon vermutest, könnte es ein RAM Fehler sein. Schau mal hier

http://hardware.speccy.org/reparar-i.html

Wird einer (oder mehrere) der RAM Bausteine wärmer als die anderen?
Lieben Gruß Torsten
BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

HarleyStone
User
Beiträge: 5
Registriert: 01.02.2019, 15:27

Re: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

Beitrag von HarleyStone » 01.02.2019, 17:11

Danke für die Info.

Mich wundert halt nur, dass der Bildschirm nach ein paar Sekunden komplett schwarz wird, anstatt schwarz/weiß zu bleiben. Deutet vielleicht noch zusätzlich auf einen anderen Fehler hin.

Hatte das Gerät auch mehrmals getestet. Bei einem Versuch war der Screen schwarz und der Rand lila. Bei einem weiteren dann wieder schwarz/weiß mit einem Signalton, der sich ständig wiederholt (piep - piep - piep usw.). Aber bei 9 von 10 Versuchen startet der Rechner nur schwarz/weiß und wird dann schwarz.

Muss nachher nochmal die Temperatur der einzelnen RAMs über prüfen.

Frag mich auch, warum das Teil nach dem Ersetzen der Elkos so spinnt. Vielleicht hatte ja der RAM schon vorher was weg (wie im ersten Post schon erwähnt). Hab leider aktuell keinen 4464er Speicher zum Testen mehr da.

Benutzeravatar
ZX-Heinz
User
Beiträge: 1606
Registriert: 05.12.2011, 14:45

Re: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

Beitrag von ZX-Heinz » 01.02.2019, 17:57

Ist an Pin11 von IC9 Spannung vorhanden?

HarleyStone
User
Beiträge: 5
Registriert: 01.02.2019, 15:27

Re: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

Beitrag von HarleyStone » 01.02.2019, 19:01

Hab hier ca. 8.5V beim TEA2000. Vorhin hatte ich nen schwarzen Bildschirm mit rotem Rand.

HarleyStone
User
Beiträge: 5
Registriert: 01.02.2019, 15:27

Re: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

Beitrag von HarleyStone » 02.02.2019, 12:24

Problem gelöst. Hatte doch noch eine Möglichkeit den RAM zu testen, da einer meiner Tandys (CoCo2) auch 4464er verbaut hatte. hab dann zwei aus dem Sinclair (IC3 und IC4) in den Tandy gesteckt und er hatte nen Fehlerscreen. Konnte es dann auf einen Speicher eingrenzen. Der Sinclair funktioniert nun einwandfrei mit dem Ersatz aus dem Tandy. Da wurde es gleich wieder mal Zeit, ein paar 4464er zu bestellen.

shock__
User
Beiträge: 31
Registriert: 25.01.2019, 20:20
Wohnort: Berlin (Kreuzberg36)

Re: ERLEDIGT: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

Beitrag von shock__ » 02.02.2019, 12:38

64k*4 DRAMs sind inzwischen auch recht ausfallfreudig wie's scheint (im C64C is das inzwischen auch häufig 'ne Fehlerursache).
Freut mich, dass du das Problem gefunden hast.
ZX Spectrum Issue 2 (Fuller FDS Gehäuse + S-Video + internal AY), ZX Spectrum Issue 3 (Timex Gehäuse), ZX Spectrum Issue 4 (ohne Gehäuse), TK90X, Pentagon48 (mit 128er Fixes + AY), ZX Sprinter 2016

HarleyStone
User
Beiträge: 5
Registriert: 01.02.2019, 15:27

Re: ERLEDIGT: Sinclair ZX +2A - Probleme, schwarzer Bildschirm, weißer Rand

Beitrag von HarleyStone » 06.02.2019, 13:45

Danke. Ja, läuft wieder wie ne 1.

Antworten