ZX-Backplane

ZX-Team Forum
Benutzeravatar
siggi
User
Beiträge: 2083
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZX-Backplane

Beitrag von siggi » 15.06.2017, 18:25

PokeMon hat geschrieben:
15.06.2017, 18:07
siggi hat geschrieben:
14.06.2017, 16:39
Wie schon bemerkt wurde, hat das "VDRIVE allgemein" keine Adresse.

Bisher wurde das VDRIVE über einen Port der PIO angesteuert. Möglich sind also alle PIO-Adressen (und ja: wer will, assembliert sich den Treiber auf die von ihm gewünschte Adresse, jeder so wie er will, sofern er ASDIS hat und benutzt :mrgreen: )
Das wäre mir jetzt neu. Ich beziehe mich natürlich auf Ollies Sparschaltung. Die gibt es seit 2011, wenn ich das richtig deute und hat eine festgelegte Adresse. Warum muss man jetzt immer das Rad neu erfinden und sich ständig neue IO Adressen ausdenken und sich jeder Nutzer die Treiber dazu selbst kompilieren ? Also so wird das nie was mit einer ZX81 einigermaßen einheitlichen IO Adressliste. :shock:
Das mag neu für DIch sein, nicht aber die anderen, die seit Tom das Vdrive an die PIO angeflanscht hatte, schon USB-Sticks am Zeddy benutzen (und das schon lange vor Ollis Sparinterface). Und da Du allgemein nach VDRIVE-Adresse gefragt hast, hatte ich halt auch auf das PIO-Interface verwiesen. Hier ist der Anfang des USB-Sticks am Zeddy ("jetzt" wurde also nichts neu erfunden):

viewtopic.php?f=2&t=179&p=769&hilit=USB+Stick#p769

Gruß
Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Benutzeravatar
PokeMon
User
Beiträge: 4404
Registriert: 31.08.2011, 23:41

Re: ZX-Backplane

Beitrag von PokeMon » 15.06.2017, 18:39

ZX-Heinz hat geschrieben:
15.06.2017, 18:22
@pokemon: Ollis Sparschaltung ist eines von vielen Interfaces für das Vdrive. Das "VDRIVE allgemein" hat keine Adresse. Und eigene Treiber braucht man je nach Maschine: Also für ZX81, für ZX81NU und H4TH. In jeder Maschine liegen die Treiber und die nötigen RAM-Adressen naturgemäß woanders. Im NU hängt beispielsweise alles noch von Inhalt des Registers E(?) ab.
Auch gut, dann schmeisse ich das raus aus der IO Adressliste. :wink:

Warum in jeder Maschine die Treiber und nötigen RAM Adressen "naturgemäß" ? woanders liegen, ist mir ein Rätsel. Die Unterschiede zwischen ZX81 und ZX81NU sind nur marginal und H4TH ist ja gar keine eigene Maschine sondern allenfalls ein anderes ROM. Welches sowohl im ZX81 als auch im ZX81NU läuft. So gesehen hätte man dann ja schon 4 "Maschinen". Die sich kaum unterscheiden.
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
tokabln
User
Beiträge: 1069
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: ZX-Backplane

Beitrag von tokabln » 15.06.2017, 19:10

Hallo Karl,

/BUSCS wird von der H4TH Card genutzt... das ist nicht das Problem.

Ich verfolge gerade eine Idee von Heinz... hinsichtlich einer eventuell notwendigen Signalverzögerung. Wenn die Karte mit Deinem ZX81XT Extender mit external/internal RAM angeschlossen ist, funktioniert sie einwandfrei. Nur im Zusammenspiel mit dem BusDriver eben nicht. Ich schau mal ob das gefixt werden kann. Da die Karte eh, auch auf Grund meiner dussligen ZX81 Edge Connector / VG64 Anschlußmöglichkeit eh überarbeitet wurde, kann dann ggf. auch ein Fix noch mit rein falls weiteres Interesse an der Karte besteht. Bis jetzt haben sich 4 Leute geoutet wobei ich heute für Siggi und Joachim (2 von den 4) die VG64 only Version verpackt habe, welche morgen in die Post geht.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
ZX-Heinz
User
Beiträge: 1270
Registriert: 05.12.2011, 14:45

Re: ZX-Backplane

Beitrag von ZX-Heinz » 15.06.2017, 23:05

Hallo Torsten,
vielleicht greifst Du einmal siggis Vorschlag
viewtopic.php?f=2&t=2141&start=500#p30670
auf. Dann hast Du ein anderes Timing im Treiberprogramm, und außerdem können dann siggi und Joachim, die ja auch Deine backplane betreiben, entsprechende Versuche anstellen.

Benutzeravatar
siggi
User
Beiträge: 2083
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZX-Backplane

Beitrag von siggi » 16.06.2017, 10:08

PokeMon hat geschrieben:
15.06.2017, 18:39
ZX-Heinz hat geschrieben:
15.06.2017, 18:22
@pokemon: Ollis Sparschaltung ist eines von vielen Interfaces für das Vdrive. Das "VDRIVE allgemein" hat keine Adresse. Und eigene Treiber braucht man je nach Maschine: Also für ZX81, für ZX81NU und H4TH. In jeder Maschine liegen die Treiber und die nötigen RAM-Adressen naturgemäß woanders. Im NU hängt beispielsweise alles noch von Inhalt des Registers E(?) ab.
Auch gut, dann schmeisse ich das raus aus der IO Adressliste. :wink:

Warum in jeder Maschine die Treiber und nötigen RAM Adressen "naturgemäß" ? woanders liegen, ist mir ein Rätsel.
Das "Rätsel" ist einfach zu lösen:
Im NU liegt Ollis Treiber im "Shadow ROM" in Page 3 (eingeblendet ab Adresse 0) und nutzt das "Shadow Ram" bei 8192. "Naturgemäß" muss das beim ZX81 anders sein, denn er hat keine Shawdow-Dingens. Dort liegt der der Treiber oft bei 8192, wodurch man Speicherblöcke z. B. ab 16K, 32K, 48K abspeichern/laden kann. Wenn man dageben bei 8192 was laden/speichern will, muß der Treiber "naturgemäß" wo anders liegen, meist ab 32K, machmal ab 40K.

Und da das H4TH-Rom eine ganz andere Speicherverwaltung als das BASIC-Rom hat, sind da "naturgemäß" andere Speicherbereiche zur Ablage des Treiber frei.
Die Unterschiede zwischen ZX81 und ZX81NU sind nur marginal
Guter Witz :mrgreen:
Shadow-Ram/Rom, 32kB ROM, ZX80-Rom-Image, 128KB Ram (brutto), Rom-Patch für SAVE/LOAD sind natürlich nur "marginale" Unterschiede zum ZX81 mit 1K Ram :roll:
und H4TH ist ja gar keine eigene Maschine sondern allenfalls ein anderes ROM. Welches sowohl im ZX81 als auch im ZX81NU läuft.
wie schon geschrieben: mit komplett anderer Speicherverwaltung und andere Einbettung des Treibers
So gesehen hätte man dann ja schon 4 "Maschinen". Die sich kaum unterscheiden.
"Ah ja" würde Loriot dazu wohl sagen ... :wink:

Gruß
Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Benutzeravatar
ZX-Heinz
User
Beiträge: 1270
Registriert: 05.12.2011, 14:45

Re: ZX-Backplane

Beitrag von ZX-Heinz » 16.06.2017, 10:33

siggi hat geschrieben:
16.06.2017, 10:08
Und da das H4TH-Rom eine ganz andere Speicherverwaltung als das BASIC-Rom hat, sind da "naturgemäß" andere Speicherbereiche zur Ablage des Treiber frei.
Genauer: Die Treiber liegen im 16kB-ROM ab #2000 bzw. beim NU mit 8k-ROM ab #1501 (die LOAD/SAVE-Routinen für TAPE wurden überschrieben). Der Forth-Befehl
' RD HEX .
(Apostroph ' mit Shift D)
zeigt z.B. die HEX-Adresse von RD (read Byte) im ROM in der jeweiligen Maschine. RD legt das gelesene Byte auf dem Stack ab. Der ist z.B. beim ZX81 von BASIC aus gar nicht zugänglich.

Benutzeravatar
PokeMon
User
Beiträge: 4404
Registriert: 31.08.2011, 23:41

Re: ZX-Backplane

Beitrag von PokeMon » 16.06.2017, 15:50

siggi hat geschrieben:
16.06.2017, 10:08
Dort liegt der der Treiber oft bei 8192, wodurch man Speicherblöcke z. B. ab 16K, 32K, 48K abspeichern/laden kann. Wenn man dageben bei 8192 was laden/speichern will, muß der Treiber "naturgemäß" wo anders liegen, meist ab 32K, machmal ab 40K.
Genau da liegt glaube ich die Wurzel allen Übels. Wenn man das VDRIVE einfach nur benutzt um Programme ordnungsgemäß zu laden, die in den 16k Speicher passen, dann hätte man eine einfache Lösung. Im Speicher umherwandelnde Treiber und wenn der Zeddy noch Kochen und Abwaschen und Staubsaugen soll, das verkompliziert natürlich alles. Manchmal ist weniger mehr. :wink:
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
siggi
User
Beiträge: 2083
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZX-Backplane

Beitrag von siggi » 16.06.2017, 16:17

Genauso hat Clive gedacht: mit seinen Tape-Routinen kann man nur Programme ordnungsgemäß laden. Das war die einfache Lösung, die hatte man schon :mrgreen:
Aber manchmal ist mehr doch mehr (war jedenfalls die Meinung vieler im ZxTeam). Und so kann der Zeddy nun mehr, als Clive dachte :mrgreen:

PS: Und im hohen Speicher wandeln nicht nur Treiber umher, sondern auch
- Applikationen (z. B. ZF-32K, NFM-32K, UFM-32K)
- Daten (Text von ZEDIT)
- Bilder (HIRES)
- Mussig (PT3- und andere Sound-Dateien)
- BASIC-Programme, die verschoben werden sollen (auf USB-Stick oder TNFS-Server
- Filesysteme (z. B. im ZX81-Web-Server)
usw. usf.
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Benutzeravatar
tokabln
User
Beiträge: 1069
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: ZX-Backplane

Beitrag von tokabln » 17.06.2017, 16:17

Moin, moin liebe ZXler,

von meiner Seite mal ein Zwischenfazit zum Thema Backplane und den bisherigen Karten:

Alle Sendungen bis auf msch und Jungsi sind soweit raus. Bei den beiden letztgenannten fehlen mir noch die korregierten BusDriver Karten. Sobald die da sind, geht also auch die Sendung an Mathias und Gerhard raus. In der Zwischenzeit werde ich Eure anderen bestellten Karten zusammen bauen. Sobald die dann hoffentlich korrekten BusDriver Karten für den ZX81 Edge Connector vorliegen, gehen auch Ersatzkarten an Erwin und Werner raus.

Was die H4TH Karte angeht, so funktioniert diese im Moment nur ohne BusDriver und/oder Backplane. Ich werde mich die kommenden Tage mal dran machen und schauen ob ich das Problem eingrenzen kann. Da ich noch ein ZX Vdrive von Stefan habe, werde ich das mal so anschliessen wie Heinz das gemacht hat, dann kann ich mal Signale vergleichen und hoffentlich das Problem eingrenzen.

Aktuell hat Erwin Probleme im Zusammenspiel BusDriver ZXBlast... hier wird ein völlig zerrissenes Videobild angezeigt. Ich habe mal ein Bild, das Erwin gemacht hat, an Karl gesandt in der Hoffnung das er eventuell einen Hinweis geben kann. Auch gibt es wohl intermittierende Probleme mit Erwins USB Tastaturkarte. Ich hoffe auch hier eine Lösung finden zu können.

Ansonsten sind alle bisher versandten Pakete hoffentlich bei allen anderen angekommen, von Siggi habe ich heute Rückmeldung bekommen, das sein gestern versandtes Paket heute angekommen ist. Paul/Joachim... wäre nett wenn Ihr mir auch eine Rückmeldung geben könnt.

Was die Doku angeht, so habe ich diese für die H4TH Karte an die von Heinz erstellte Doku des von Ihm aktuallisierten H4TH Eproms Version II angepasst und Siggi sowie Joachim gesandt. Das aktuallisierte EPROM und Heinz Doku sind im Forum aktuell verfügbar. Alle noch ausstehenden Karten werde ich die Tage im Rahmen des Zusammenbaus für Mathias und Gehard beschreiben und dann die Doku an alle Kartenbesteller versenden. Diese Doku ist von der Dateigrösse leider zu groß um sie ins Forum stellen zu können. Daher werde ich diese an die privaten eMail Adressen versenden.

Soweit mal von meiner Seite... sollte es Anmerkungen geben, dann bitte entweder hier in diesen Thread stellen oder per PN an mich. Danke.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
PokeMon
User
Beiträge: 4404
Registriert: 31.08.2011, 23:41

Re: ZX-Backplane

Beitrag von PokeMon » 17.06.2017, 20:44

Ich nehme mal an, dass Erwin das CPLD nicht aktualisiert hat.
Da hatte ich ja angeboten, das nach Zusendung neu zu programmieren und wieder zurückzusenden.
Ich glaube davon hatte Erwin bisher kein Gebrauch gemacht.

In der ersten CPLD Version war ja ein Fehler in der Ansteuerung des Bus Signals.
Siehe auch:
viewtopic.php?f=2&t=2141&start=300#p28918
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
tokabln
User
Beiträge: 1069
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: ZX-Backplane

Beitrag von tokabln » 17.06.2017, 21:17

Hallo Karl,

Danke für die Info... da hab ich echt nicht mehr dran gedacht. Ich hab eben Grautier über Deine Antwort informiert und Ihn gebeten erstmal das CPLD durch Dich auf den aktuellen Stand bringen zu lassen. Dann können wir sehen ob sein Problem dann weg ist.

Frage: Du hattest ja auch noch letzte Updates an Siggi und Joachim gesandt... ist das jetzt die letzte Version so dass ich Dir mein CPLD auch zusenden kann?

LG und einen schönen Sonntag
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
PokeMon
User
Beiträge: 4404
Registriert: 31.08.2011, 23:41

Re: ZX-Backplane

Beitrag von PokeMon » 17.06.2017, 21:39

Ja kannst Du bei Gelegenheit nochmal schicken für den aktuellen Stand.
Wer seinen Computer ehrt, lebt nicht verkehrt.

Benutzeravatar
Grautier
User
Beiträge: 345
Registriert: 18.11.2013, 18:44
Wohnort: Mühldorf

Re: ZX-Backplane

Beitrag von Grautier » 18.06.2017, 08:30

PokeMon hat geschrieben:
17.06.2017, 20:44
Ich nehme mal an, dass Erwin das CPLD nicht aktualisiert hat.
Da hatte ich ja angeboten, das nach Zusendung neu zu programmieren und wieder zurückzusenden.
Ich glaube davon hatte Erwin bisher kein Gebrauch gemacht.
Das hatte ich tatsächlich überlesen! Das wird dann wohl mein Problem sein. Ich schicke dir eine PN.

Benutzeravatar
siggi
User
Beiträge: 2083
Registriert: 06.12.2005, 08:34
Wohnort: D, Hessen, tiefste Werreraa
Kontaktdaten:

Re: ZX-Backplane: Variationen in MINI

Beitrag von siggi » 02.07.2017, 12:06

Torstens Mini-Backplane (die ich ja in größerer Stückzahl von Torsten erhalten habe: nochmal Dank dafür), finde ich sehr universell, denn man kann sie in vielen Varianten bestücken. Hier erstmal die einfachsten Varianten: links als Kartenverlängerung für Einsatz halber Karten im Standard-Rack, rechts als "Mini-Backplane" mit 2 Slots (oder 1 Slot und Stecker für weitere Mini-Backplane:

P1120593_640x480.JPG
P1120593_640x480.JPG (101.57 KiB) 789 mal betrachtet

Hier aber noch eine etwas ungewöhnlichere Bestückung: da habe ich 2 Buchsenleisten in P2 und P3 bestückt und eine Buchsenleiste mit langen Pins in P1 (von der Rückseite her. Vorne links liegt so eine nochmal).

Damit hat man dann Anschluß für 2 Karten, die "nach vorne" weggehen, den Anschluß an den Zeddy über die langen Pins des P1. Und zudem einen Anschluß für eine weitere Karte "nach hinten" über P1 (also ingesamt 3 Karten):

P1120595_640x480.JPG
P1120595_640x480.JPG (102.83 KiB) 789 mal betrachtet

Bei der obersten Buchsenleiste habe ich auch eine mit langen Pins genommen, da könnte man bei Bedarf auch noch einen Busabschluß dranstecken (falls notwendig).

Und damit kann man dann den Zeddy mit 2 Erweiterungskarten so kompakt aufbauen (in ein Standard-Gehäuse), wie Joachim das mit seinem ZXNU und selbsgefräster Platine gemacht hat (siehe viewtopic.php?f=2&t=2148&p=27782#p27782).
Aber hier häte man dann zusätzlich die Anschlußmöglichkeit einer weiteren Karte außerhalb des Gehäuses.

Hier Zeddy-Board mit ZxBlast und Zeddy-Net-Karte

P1120594_640x480.JPG
P1120594_640x480.JPG (110.39 KiB) 789 mal betrachtet

Allzeit frohes Löten
Siggi
Mein ZX81-Web-Server: online seit 2007
http://zx81-siggi.endoftheinternet.org/index.html

Benutzeravatar
tokabln
User
Beiträge: 1069
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: ZX-Backplane

Beitrag von tokabln » 02.07.2017, 12:30

Danke siggi für die schönen Bilder.

Ich überlege ob ich der MiniBackplane nicht noch die Möglichkeit zum anschliessen eines ZX81 Edge Connectors für P1 bzw. P3 spendiere.
Mal sehen ob ich das irgendwann mal umsetzte.

Wünsche noch einen schönen Sonntag.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
tokabln
User
Beiträge: 1069
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: ZX-Backplane

Beitrag von tokabln » 03.07.2017, 19:20

Sodele,
lange hat es gedauert und dafür möchte ich mich auch ein wenig entschuldigen, aber Stand heute sind nun alle Bestellungen bei mir raus.
Hoffentlich sind alle Pakete, bis auf Jungsi's Paket welches heute als letztes raus ging, auch angekommen.

Ich hoffe das alle soweit zufrieden sind und ich möchte mich hier nochmal für die Hilfe bei der Entwicklung der bis jetzt erhältlichen Karten und Boards bei allen Unterstützern bedanken. Auch wenn es sehr zeitintensiv war, so hat es doch viel Spaß gemacht und ich denke das eine oder andere Kärtchen wird im Laufe der Zeit noch dazu kommen.

Die H4TH VDrive Karte hat leider noch ein paar Macken und läuft so erstmal wirklich nur direkt an einem FORTH Zeddy mit 16KB (32KB) RAM. Es wird, wenn ich das Problem eingekreist habe dann sicher eine überarbeitete Version angeboten, die dann so der Plan auch am BusDriver funktionieren soll.

Dazu stehen aber noch einige Messungen und Vergleiche aus und ich muß erstmal sehen wo ich einigermaßen kostengünstig SKS Hirschmann KLEPS 3ST Miniatur Greifklemmen herbekomme, da ich da 32 rote und 4 schwarze für meinen alten HP Logikanalyzer benötige. Wenn jemand eine Quelle kennt, die bei dieser Menge bei 3Euro oder weniger pro Stück liegt bitte Bescheid geben. Mit dem BusPirate V3.6 und seinen maximal 5 Signalen im Analyzer Mode ist das eine elende Fummelei und die Prüfklemmen sind leider nicht so schön wie die Hirschmann Teile. Naja.

Ich freue mich wenn alle Boards und Karten soweit wie geplant funktionieren und Ihr Euern Spaß damit habt.

Wünsche einen schönen Feierabend...
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
Joachim
User
Beiträge: 865
Registriert: 06.11.2004, 20:21

Re: ZX-Backplane

Beitrag von Joachim » 06.07.2017, 07:52

Hallo Siggi!
Das nennt man dann ja wohl ZXikebana. In meinem Kopf entsteht gerade ein ZXcube :wink:
Viele Grüße!
Joachim


ZX80, ZX81, ZX-Spectrum, ZX96, ZX2000, ZXmore, ZX81NU, Blauer Engel, AX81

Benutzeravatar
msch
User
Beiträge: 3312
Registriert: 05.02.2013, 15:42
Wohnort: Hessen, Rhein-Main-Gebiet

Re: ZX-Backplane

Beitrag von msch » 07.07.2017, 16:11

tokabln hat geschrieben:
03.07.2017, 19:20
Ich hoffe das alle soweit zufrieden sind und ich möchte mich hier nochmal für die Hilfe bei der Entwicklung der bis jetzt erhältlichen Karten und Boards bei allen Unterstützern bedanken. Auch wenn es sehr zeitintensiv war, so hat es doch viel Spaß gemacht und ich denke das eine oder andere Kärtchen wird im Laufe der Zeit noch dazu kommen.
Auch ich möchte mich bedanken - heute kam ein schönes Paket aus Berlin an :-)
Also: Hut ab, saubere Arbeit!

Ich hoffe ja sehr, dass man Dich auch einmal bei einem ZX-Team Treffen sehen wird...

Nochmal herzlichen Dank!

Beste Grüße

Mathias

P.S.: die roten Klemmen gibt es bei Reichelt für 3,59 https://www.reichelt.de/Klemmen-Pruefsp ... CLE=106204 und in der Bucht für 3,51
Zuletzt geändert von msch am 07.07.2017, 16:17, insgesamt 1-mal geändert.
manche meinen lechts und rinks kann man nicht velwechsern.
werch ein illtum! (Lichtung, Ernst Jandl)

Benutzeravatar
tokabln
User
Beiträge: 1069
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: ZX-Backplane

Beitrag von tokabln » 07.07.2017, 16:17

Hallo Mathias,

lieben Dank für die Blümchen.

Das Paket kam echt erst heute an? Wow... ich habe das Ende der letzten Woche abgesandt.
Dann hoffe ich, dass das Paket von Jungsi nicht auch so lange braucht. Das habe ich am Montag abgegeben.

Hinsichtlich Mahlerts muß ich mal schauen.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
Jungsi
User
Beiträge: 632
Registriert: 05.10.2012, 13:53
Wohnort: Simbach am Inn
Kontaktdaten:

Re: ZX-Backplane

Beitrag von Jungsi » 07.07.2017, 21:30

Nein - vielen Dank für Deine Mühen!
Mein Paket war schon am Mittwoch da :-)
Vieles rund um Sinclair und andere Retro-Computer:
http://www.jungsi.de

Benutzeravatar
Grautier
User
Beiträge: 345
Registriert: 18.11.2013, 18:44
Wohnort: Mühldorf

Re: ZX-Backplane

Beitrag von Grautier » 11.07.2017, 09:55

Auch von mir vielen Dank für deine Arbeit!

Dank des neuen CPLD für das ZX-Blast funktioniert jetzt fast alles.

Mein PS/2 (USB) Tastatur Interface funktioniert bei mir noch immer nicht, sobald ich die Backplane mit dem Bustreiber verwende, ohne geht es. Ich denke, es liegt jedoch am Tastatur-Interface. Ich werde bei Gelegenheit (heute Abend) besser im Forums-thread viewtopic.php?f=2&t=1829 über das Interface von meinen Problemen berichten.

Benutzeravatar
tokabln
User
Beiträge: 1069
Registriert: 10.11.2013, 00:24
Wohnort: D, Berlin (Mariendorf)

Re: ZX-Backplane

Beitrag von tokabln » 11.07.2017, 12:58

Ich habe leider kein Tastatur Interface und kann das daher leider nicht testen.

Morgen sollen aber wohl meine dann doch bestellten KLEPS 3ST Prüfklemmen kommen und dann kann ich auch hoffentlich dem H4TH Interface auf den Zahn fühlen, warum das am BusDriver nicht mag. Vielleicht könnte das dann auch einen Fingerzeig für das Tastatur Interface liefern.
Lieben Gruß Torsten
BMZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500, Amiga 1200, Atari Portfolio, HP200LX, IBM PC 5155, TP755c, T41, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e

Benutzeravatar
Joachim
User
Beiträge: 865
Registriert: 06.11.2004, 20:21

Re: ZX-Backplane

Beitrag von Joachim » 11.07.2017, 14:04

Hallo Grautier!
Das PS/2-Interface funktioniert bei mir am Backplane mit ZXblast und Treiber tadellos. Auch damals schon, als wir die Backplane und den Treiber getestet haben. Eben habe ich alles nochmals aufgebaut und es gab keine Probleme. Weder mit unbuffered noch mit buffered Clock. Hast du die Diode für /BUSCS eingelötet? Ist es eine Shottky? Wie ist dein Setup? Vielleicht kann ich es nachstellen.
Viele Grüße!
Joachim


ZX80, ZX81, ZX-Spectrum, ZX96, ZX2000, ZXmore, ZX81NU, Blauer Engel, AX81

Benutzeravatar
Grautier
User
Beiträge: 345
Registriert: 18.11.2013, 18:44
Wohnort: Mühldorf

Re: ZX-Backplane

Beitrag von Grautier » 11.07.2017, 15:53

Joachim hat geschrieben:
11.07.2017, 14:04
Hast du die Diode für /BUSCS eingelötet? Ist es eine Shottky? Wie ist dein Setup? Vielleicht kann ich es nachstellen.
:oops:
nein, keine drin.
:oops:
Vielen Dank für den Hinweis! Ich denke eine Bat42 oder 46 Shottky Diode tut es? Beide habe ich da.

Edit: Schon passiert (mit BAT46). Das Interface funktioniert jetzt. Ich hatte noch einen Schnelltest mit Tastaturinterface, Mr. X und ZX-Blast gemacht.
Da hast du wieder mal einem Unwissenden geholfen! Mein Mr. X hatte eine Diode drin - ich habe gerade gesehen, bei meiner PIO und Zeddynet fehlt diese auch!
backplane2 - 1.jpg
backplane2 - 1.jpg (175.34 KiB) 564 mal betrachtet

Benutzeravatar
Joachim
User
Beiträge: 865
Registriert: 06.11.2004, 20:21

Re: ZX-Backplane

Beitrag von Joachim » 11.07.2017, 16:28

Freut mich, dass alles funktioniert!
Viele Grüße!
Joachim


ZX80, ZX81, ZX-Spectrum, ZX96, ZX2000, ZXmore, ZX81NU, Blauer Engel, AX81

Antworten